CLK 722.6 Gearbox issues

jenglish

New Member
Joined
Oct 24, 2013
Messages
29
Location
London Heathrow
Car
A209 CLK320
Hello,
I have a CLK 320 2005 convertible petrol.
My old gearbox is a 5G speed 722.6 had leaking issues and water contamination.
So i bought a 2nd hand gearbox and installed a new radiator too.
The problem im facing is that the 2nd hand gearbox had green transmission fluid not burnt it was a healthy green color.So i drained it out.
With the gearbox installed the propshaft didnt align with the back of the gearbox.It was about 5mil bigger.So i took it off my original gearbox and put it on the 2nd hand box.
Everything fits fine now,and also has a new original conductor plate too.Garage filled it up with red fluid.

Now when i drive in S mode (standard) it pulls away in first gear and so on which is fine.i took it down the motorway and gears changed as it should.
After about 10 mins or so when i come to a built up area my gears seem to be stuck in either 3rd or 4th gear.Even when i pull away it seems to be pulling away in the wrong gear and i can only drive upto 40MPH as the gears wont change.
Even in stationary i tested it manually by putting it drive the flicking it left and right (paddle style) to see if gears 1234 etc would show up manually on my dash...in which case it did...then sometimes it wont change on my dash just stays in Drive

The next day or a good few hours when you pull away it pulls in the correct gear then gets stuck in 3rd gear again i believe.
I hooked up my scanner and got 2 error codes :

P2561 The gear is implausible or the transmission is slipping (2.Gear)
P2560 The gear is implausible or the transmission is slipping (1.Gear).


Do you think it might be a bit of contamination in the valve body with green fluid?
Or my TCM is playing up?
or Gear ratio is different to my original box?

Also i would like to know which car this gearbox came out of.They sold it to me reassuring me it came out of a CLK320.

My car is a CLK320 2005 petrol convertible 5speed
My original gearbox number is 722.6 180
2nd hand gearbox 722.6 440

How do i find out what car did the 2nd hand gearbox come out of?
see attachments.

Many thanks
 

Attachments

  • 2nd hand gearbox.jpg
    2nd hand gearbox.jpg
    352.8 KB · Views: 10
  • Error_code.jpg
    Error_code.jpg
    353.3 KB · Views: 8
  • error_code2.jpg
    error_code2.jpg
    279.6 KB · Views: 9
  • originalgearbox.jpg
    originalgearbox.jpg
    278.9 KB · Views: 9
  • prop1.jpg
    prop1.jpg
    181.8 KB · Views: 9
  • prop2.jpg
    prop2.jpg
    186.5 KB · Views: 9
  • TCM.jpg
    TCM.jpg
    191.9 KB · Views: 10

pmcgsmurf

MB Enthusiast
SUPPORTER
Joined
Feb 22, 2010
Messages
5,064
Location
Stirling, Scotland
Car
E55 AMG W211, E250 Sport W212, (and some Imps)
Can't help sorry but green fluid would have me worried.

Should have been easy to get the VIN from the seller to confirm that the gearbox was/is suitable.
 
OP
OP
jenglish

jenglish

New Member
Joined
Oct 24, 2013
Messages
29
Location
London Heathrow
Car
A209 CLK320
Im seeing this issue, Car had water damage from the past..curious if this is causing the car to go into limp mode.
Im not getting esp abs issues on my dash.But seems not communicating with the TCM?
 

Attachments

  • canbus.jpg
    canbus.jpg
    231.9 KB · Views: 7

91dm

Active Member
Joined
Oct 6, 2010
Messages
954
Location
Irl / Uk
Car
A few
Did they change the filter or just the fluid?
 
OP
OP
jenglish

jenglish

New Member
Joined
Oct 24, 2013
Messages
29
Location
London Heathrow
Car
A209 CLK320
Did they change the filter or just the fluid?
Fluid filter nd conductor plate changed..ive done the tcm too..

When i switch the car off then back on it works for a while..everytime i turn into my road and put it in reverse..goes back into limp mode..strange.. fluids nice cherry red too .... mechanically i think the gearbix is good..my guess is has to be electrical
 

91dm

Active Member
Joined
Oct 6, 2010
Messages
954
Location
Irl / Uk
Car
A few
I read somewhere before about a gearbox fitted with slightly different ratios and the output speeds didn't match the wheel speed sensors which threw it into limp mode? Not sure if there's a solution for this apart from reprogramming or if that is even the case here.
 

merc85

MB Enthusiast
SUPPORTER
Joined
Apr 23, 2013
Messages
9,301
Location
Harwich
Car
s211 e55k
ALL 722.6 Gearbox's took RED ATF,

Id change the fluid and filter again and drain the TC, Dare i say it another Conductor plate too.

If your handy with the spanners it would pay you to take the valve body apart and clean that out aswel.
 
Last edited:

91dm

Active Member
Joined
Oct 6, 2010
Messages
954
Location
Irl / Uk
Car
A few
Forgot to ask if you have checked the fluid level cold and warm since it was changed? Initially I thought it's electrical due to the faults logged.
 

BlackC55

Authorised Forum Sponsor
SUPPORTER
Joined
Feb 8, 2007
Messages
19,767
Location
Portsmouth, Hampshire.
Car
E55K SL500 E250X2 Smart44 Brabus Track car E450Cabriolet X350 Pick up
Its the wrong gearbox. It needs to be exactly the same number. Been there and got the T shirt.

NOT one single second hand gearbox that I've been supplied in 22 years has worked when I have fitted it.
 
OP
OP
jenglish

jenglish

New Member
Joined
Oct 24, 2013
Messages
29
Location
London Heathrow
Car
A209 CLK320
Its the wrong gearbox. It needs to be exactly the same number. Been there and got the T shirt.

NOT one single second hand gearbox that I've been supplied in 22 years has worked when I have fitted it.
Same number as the last 3 digits after 7226..? Or can i go by the vin number?
 

Users who are viewing this thread

Top Bottom