CLK55 (C209) Won't start - P0112 error

Page may contain affiliate links. Please see terms for details.


Dec 2, 2012
CLK55 (C209)
Strange issue with my CLK today. Headed off to work and car started fine, then 2 minutes up the road, I remembered that I'd forgotten something so headed back home. Pulled up outside and ran in the house to grab what I needed (was in the house all of 2 minutes) and then came back out, jumped in the car, and now I just get this noise of presumably the starter motor trying to start the engine, but doesn't actually crank.

I have an ELM327 WiFi OBDII gizmo and an app on my phone called "FourStroke" which pulls up the error codes on the car, and I'm getting a P0112 error code.

Feel like I'm going down the rabbit hole with this one as so far from looking on google, from what I can tell it could be the MAF sensor, the CPS, the fuel pump or an electrical fault! :-(

What's making me think that maybe it's not the CPS is that it doesn't start regardless of whether the engine is hot or cold, and I've read that normally if the CPS is faulty, it will normally work if you let it cool down for half an hour or so. It makes no difference and still won't start even after leaving the car for two hours.

What's making me think its' not the MAF sensor, is that most people say a MAF issue really affects vehicle performance, but won't stop the car from actually starting.

I guess it could be the fuel pump, but wouldn't that bring up a different fault code? I can clear the P0112 code with the app, then turn the key, hear the noise and the error code comes straight back again.

I checked the fuse in the boot for the fuel pump and that looks fine. I also swapped the relay for another identical one I borrowed from the fuse board under the bonnet (Hella 12v 4RA 002 542 26 19) that does another job, but that still didn't work so doubt it's that.

I uploaded a quick video of the noise (unfortunately the sound isn't great - Also please ignore the 3-4 "dunk" noises at the start of the video as that's an unrelated issue of a plastic cog hidden away behind the dash that controls air-con direction...apparently a common fault on the CLK's)

YouTube clip of car not starting

What do you guys think?

What I'm thinking I'll do is firstly change the CPS (this one)
and if that doesn't work, then change the MAF (this one)

and either of those don't work then possibly a new fuel pump?

Any help/advice would be much appreciated!
In an ideal world, your car needs to be trailered to an MB specialist to have the codes read with Star which should pinpoint your problem.
Changing out parts without correct diagnosis will only hurt your wallet.
This site gives Intake Air Temperature Circuit Low Input as fault P0112.
In an ideal world, your car needs to be trailered to an MB specialist to have the codes read with Star which should pinpoint your problem.
Changing out parts without correct diagnosis will only hurt your wallet.
This site gives Intake Air Temperature Circuit Low Input as fault P0112.

thanks yeah that matches up with the fault code description on my iPhone App so it's good that it's showing the correct info for the car.

Reluctant to tow to my local MB "specialist" ..... They wanted to charge me £495 to replace the aux belt when it snapped a few months back, as opposed to a local "jack-of-all-trades" garage who said it was an easy job and charged me £140 (including the part) to sort it out.

I know this local garage doesn't have star, so I guess they'd only see the same fault code that I'm seeing, which by the looks of things doesn't appear to pinpoint an obvious fault.

I can't help feel that I'm going to get done over with this one, and I bet it ends up being something really simple to fix! :-(
My guess is CPS... Had it on mine years ago...

I've heard that generally speaking when they fail, they will still allow you to start the motor once they cool down (after say an hour) but even after 3 hours it still won't start. Was that the case for yours? I.e. it wouldn't start regardless of whether it was hot or cold?

If so, I think I'll give it a go.... looks a bit of a bugger to get to, but at least it would be a nice cheap fix!
If i remember right.. mine wouldn't start but it had had an intermittent issue up to then..... its the cheapest thing to try...
Well I committed to changing the CPS and what a nightmare it’s turning out to be to swap it out!

First of all, as I’m sure many of you know, it’s a nightmare to get at. I found a “how to” that suggested using a 1/4 12in extension bar but for the life of me I cannot see how this would be physically possible as the torx screw holding down the CPS is below the plastic “D” connector on the CPS as you aim the bar down so there was no way I could get the 8E female torx socket on to it.

Anyways after more searching around I found a far better method which is to use 2x 1/4 6in extension bars connected together with a 1/4 universal joint adaptor. That finally got me on the screw and I managed to get the thing out.

The next issue is the CPS itself. It’s like it’s been superglued in! :-(

I spent around 2 hours trying to pry the thing out. I even ordered these extra-long 400mm needle nose pliers to yank it out but it won’t budge at all. Nothing. Won’t twist, won’t rock, literally stuck fast.

Will try some WD40 penetrant tomorrow all round it tomorrow, but am slowly starting to worry this will be a dropped transmission job. I dread to think what that will cost me :-(
I find Plus Gas works better than WD40, especially if left to soak for a few hours.
Update on the nightmare I've had with the car. Couldn't get the CPS out for love nor money. After spending the best part of a week trying different things I finally gave up and had the car towed to a garage.

They had to drop the transmission to knock it out and put the new one in, however that made no difference, and the car still wouldn't start. The garage believed it to be a faulty ECU, but couldn't find anyone in the UK who would have a go at repairing it, so they shipped it off to an ECU specialist in Germany.

After a week, it got shipped back to the UK....plugged it in....still not working, so the garage called the German company, who were insisting that the ECU was the end they agreed to taking a second look at it, so the garage shipped it back to Germany......The latest I heard was that it then got shipped elsewhere to another place in Germany, and now it's back in the UK, but from what the guy at the garage tells me, he's not convinced they have fixed it, but there's no way he can prove it, as when it gets plugged in it still doesn't work.

Have no idea where I go from's been over 2 months now since I've had my car!

Is there any point throwing more money at this?
Anyone had similar issues with their ECU?

Any suggestions greatly appreciated!
The YT clips shows the engine not turning over, the same as your 1st post. The CPS stops the engine from running not cranking so it wont be that, have you checked the starter motor, solenoid and relay?
I personally didn't try that when the car was with me, but I would've thought the garage would have carried out basic checks like that. They are quite a well known garage in the local area with good reviews and they already swapped out my aux belt a year ago without issue so up until now I haven't really had any reason to question them. Wouldn't the starter motor throw a code on STAR? They are telling me that the ECU is throwing the same CPS code as when I originally took it into them.
Only just seen this thread.

When you first posted you said it didn’t crank.

You can quite clearly hear the engine cranking/turning over in the video clip (@ 14 seconds and again @ 21 seconds)

Open the bonnet if you’re in any doubt! :thumb:

I’d put money on that being a CPS fault. It’s cranking over fine but the rev counter isn’t reading.

The EML is on so there will definitely be some codes stored.

It only needs fuel and a spark to fire which it’s not doing. With no crank signal it can’t provide either of course (shuts down fuelling to prevent unburned fuel getting into the cats etc)

How did the garage diagnose an ECU fault? With no proper test equipment I’d take the word of a German ECU specialist company over someone not familiar with these cars.

Maybe you damaged the wiring or something to the CPS when trying to remove it?

Good luck, maybe try taking it to a different MB specialist if you’re not happy with the place you used in the past.

Where are you based?

Users who are viewing this thread

Top Bottom