CLS NTG1 Comand issue

Page may contain affiliate links. Please see terms for details.

clk208

MB Enthusiast
Joined
Feb 14, 2009
Messages
1,276
Location
NW
Car
CLS
The NTG1 Comand system on my CLS has been faultless for almost 12 years but just experienced the first issue.

The audio cuts out every 5secs or so, the timing of which ties in with the navigation drive in the boot hunting and struggling to read the DVD. Pressing the Nav button on the headunit it says navigation device unavailable.

I’ve removed the Nav drive and ordered a fibre optic jumper which apparently is what’s needed to close the MOST loop and test the system without the Nav drive present.

Assuming the Comand then works and it is the Nav drive in the boot at fault is laser replacement likely to cure my woes? Can I leave the fibre optic jumper connected to bypass the drive for a few weeks so I still get audio?
 
Gratuitous picture of Nav drive.

Pleasing how it came out with stereo release keys.
 

Attachments

  • 745EB5A7-F035-424C-AF51-823664C8FEE1.jpeg
    745EB5A7-F035-424C-AF51-823664C8FEE1.jpeg
    77.5 KB · Views: 10
Just to update the thread my fibre optic jumper arrived and I put in in place of the navigation drive/computer.

Comand is now fully working as expected for all other functions so my suspicions of a duff nav drive seem founded.

Now it’s just whether to try to get it repaired or source another off eBay.
 
Just to update the thread my fibre optic jumper arrived and I put in in place of the navigation drive/computer.

Comand is now fully working as expected for all other functions so my suspicions of a duff nav drive seem founded.

Now it’s just whether to try to get it repaired or source another off eBay.

Were you running a pirate nav disc?
 
I have a Nav drive (which was working faultless) when I removed it few weeks ago (upgraded to NTG 2.5)
Even have a Genuine maps disk with 2018 maps

Let me know if you are interested
 
Were you running a pirate nav disc?

No it’s always had genuine discs.

The original was in until 2017 when I updated to latest from MB dealer.
 
I have a Nav drive (which was working faultless) when I removed it few weeks ago (upgraded to NTG 2.5)
Even have a Genuine maps disk with 2018 maps

Let me know if you are interested

Excellent. This may be a good solution. How much are you looking for? PM if you prefer.

Would you be able to let me know the part number so I can double check compatibility?
 
You probably need a new laser in the nav drive. Donshl's nav drive will be fine for your car. Even if part number is different

Cheers
Richard
 
Excellent. This may be a good solution. How much are you looking for? PM if you prefer.

Would you be able to let me know the part number so I can double check compatibility?

Hi,

I’ll be back home Saturday night and can post pics and part number.

I’ll let you know the price too.

Thanks
Don
 

Users who are viewing this thread

Back
Top Bottom