CLS Right hot film mass air flow sensor above limit

Discussion in 'Engine' started by Tigerade, Jul 15, 2016.

  1. Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    Right guys I'm after some help.

    When I purchased my 2006/7 CLS cdi it needed a service, to cut a long story short it had one at my expense as the supplying Vauxhall dealer refused.

    Anyway, once serviced a few faults were found and rectified by the dealer once they agreed they were current etc.

    One of the faults was the Air flow sensor, Code:2645-001, Check component B2/7 (Right hot film mass air flow sensor ) value above limit.

    The Air flow sensor was changed by the dealer 2 month ago but the exact same fault has returned, I'm wondering if A: The dealer never changed it or B: There's a bigger issue lurking and they thought I wouldn't find out until I had it serviced after the warranty period but I have, lol.

    Thanks in advance,
    Ade.
     
    Last edited: Jul 15, 2016
  2. streethawk

    streethawk Hardcore MB Enthusiast

    Messages:
    1,018
    Joined:
    Jun 27, 2011
    Location:
    leicester
    Car:
    E320cdi sport
    If it's a v6 which iam sure it is there are 2 and if it's a proper merc dealer they change whole y shape inlet which comes with both maf's as you can't buy them separately unless you look around. £300 for this part but it's very rare these fail on v6.
     
  3. OP
    OP
    Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    Sorry, yes its a 320 V6 Diesel.

    The dealer informs me that he replaced the whole unit with a genuine MB item. The car is back in the dealers next week and believes it to be a problem elsewhere.

    But what else can bring this code on?
     
  4. streethawk

    streethawk Hardcore MB Enthusiast

    Messages:
    1,018
    Joined:
    Jun 27, 2011
    Location:
    leicester
    Car:
    E320cdi sport
    So the whole y piece with 2 maf's. ? If they replaced that thinking that was your problem and isn't then I'd tell them to put old unit back and give you you're money back and then find out the real problem.
     
  5. streethawk

    streethawk Hardcore MB Enthusiast

    Messages:
    1,018
    Joined:
    Jun 27, 2011
    Location:
    leicester
    Car:
    E320cdi sport
    Is it a merc dealer using star diagnostic. ?
     
  6. OP
    OP
    Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    The Star session was with one of the best Indies in my area, researched them, lol. I had the car put on "Star" as I wanted to make sure no faults were evident 2 months after being repaired.

    The dealer from which I purchased the car also done there own diagnostics to confirm any errors, they have changed the whole "Y" section with both airflow sensors as it's one complete section and like I say, the error has reappeared.
     
    Last edited: Jul 15, 2016
  7. streethawk

    streethawk Hardcore MB Enthusiast

    Messages:
    1,018
    Joined:
    Jun 27, 2011
    Location:
    leicester
    Car:
    E320cdi sport
    I'd assume it needs live data checking whilst on star. Give olly a ring at prestige and he'll be glad to point you in the right direction as I always ring him if iam not sure. If you live near him go there honest I would but Portsmouth is a bit far.
     
  8. OP
    OP
    Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    Its even further for me, I'm in Blackpool.
     
  9. gazz

    gazz Hardcore MB Enthusiast

    Messages:
    435
    Joined:
    Mar 9, 2006
    Has the car been remapped? I don't know why, but every v6 diesel I have seen that has been remapped throws this code, but runs perfectly. If the mil is off I wouldn't worry about it too much
     
    2 people like this.
  10. OP
    OP
    Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    I have no info as to the car being mapped or not.

    When the dealers changed the airflow sensors it did seem to go better so I'd suspect something is throwing this code but as to what I don't know.

    Like I say, the car goes well and I see a steady 46+mpg on my motorway commute at 60mph and at 79mph I see around 40mpg.
     
  11. Auto-mobile

    Auto-mobile Hardcore MB Enthusiast

    Messages:
    1,600
    Joined:
    Oct 1, 2011
    Location:
    Birmingham
    Car:
    2x c43 Amg clio 172 turbo 314bhp
    I have seen this on two occasions.
     
  12. OP
    OP
    Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    And were both cars mapped or standard?
     
  13. WG M-B

    WG M-B Auhorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    1,898
    Joined:
    May 26, 2011
    Location:
    N/W london
    Car:
    C63 Wagon in black
    If the car is driving fine but the code is getting thrown with no limp mode then I'd be sure that is a map issue
     
  14. Auto-mobile

    Auto-mobile Hardcore MB Enthusiast

    Messages:
    1,600
    Joined:
    Oct 1, 2011
    Location:
    Birmingham
    Car:
    2x c43 Amg clio 172 turbo 314bhp
    Yes both mapped.
     
  15. OP
    OP
    Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    Ok, so next question is, how can I find if it's been mapped?

    I have a raft of history but no invoices regarding any map.

    Another thing is, when the dealer changed it and the fault cleared would this happen with a map or does it have to re-learn/teach the ecu and then the fault will reoccur.
     
  16. Biltas

    Biltas New Member

    Messages:
    20
    Joined:
    Jul 18, 2016
    Car:
    Mercedes cls
    same fault

    I have same fault on my 2006 cls 320cdi, when i bougt my car 6 month ago check engine light comes on dashboard(car runs fine no limp mode mpg good) ,i plug star and snap-on diagnostic and have same fault code:2645-001, Check component B2/7 (Right hot film*mass air flow sensor*) first i try swap Right and Left maf sensors but this wont help , then leave car in garage they check maybe is air leaking but everything is fine!!! So now i want sold my car(need bigger car) but check engine light is on so i dont know what need to do (car runs fine without limp mode mpg good)
     
  17. Biltas

    Biltas New Member

    Messages:
    20
    Joined:
    Jul 18, 2016
    Car:
    Mercedes cls
    same fault

    TIGERADE is check engine light is on dashboard on your car?
     
  18. OP
    OP
    Tigerade

    Tigerade Active Member

    Messages:
    63
    Joined:
    Feb 21, 2016
    Car:
    CLS 320 diesel
    Hi Biltas,

    There are no engine check lights on my car what so ever.
     
  19. Biltas

    Biltas New Member

    Messages:
    20
    Joined:
    Jul 18, 2016
    Car:
    Mercedes cls
    same fault

    So i dont know what i need to do because car runs fine but engine check light is on! Any idea?
     
  20. t-dawg1

    t-dawg1 Hardcore MB Enthusiast

    Messages:
    561
    Joined:
    Jan 1, 2013
    Location:
    Paisley
    Car:
    Mercedes W211
    +1 mine has been remapped and has this code permanently. No mil or limp mode car drives perfectly
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.