Could I have a scn coding module bug.

zenman63

MB Enthusiast
SUPPORTER
Joined
Feb 8, 2010
Messages
2,258
Location
Warwickshire
Car
172 Slk 250 & Porsche 911 991.2 S Cayman S
I have had this problem for some time now.
No 3 flashes when locking, all doors lock and No codes on MB Star.

From the dash i can lock all doors but cannot open the front from the dash.
If i open the drivers door then the switch will open and close all doors on the dash.
Auto lock works fine.
Rear locks are fine and open and close from dash switch, red led is on the switch when locked.
There are 2 leds in that switch and only one is red, the rears.

I have swapped as follows.
Both driver and passenger front door locks, and the dash switch.
I do not get the global signal so the dash and lights inside stay on far to long.
I can open with the IR door handle but cannot close from the remote as its not getting the final lock signal.
When you press the dash switch it opens and closes the rear fine so that all must be good.
When you lock the front, it locks ok but you cannot open it, if you press again it trys to lock, lock etc, never open.

I need advance diagnostics and this is my next job that needs sorting.
I understand the ezs gets the signals from each door module and then sends it on to the sam to flash the lights, this is missing.
EZS has been swapped with a known good one to test and No change so swap back the original.
I have done a continuity test on the canbus to the front drivers side location.

When you lock an open van with the doors closed and no lights on the overhead control panel lights up.

__________________

Everything works, both front door controllers have been swapped, no change.
Doors lock first time and stay locked.
If you unlock and don't open a door it will lock again all as it should, all i am missing is the 3 flashes and the signal that goes with it.
I have no connivence closing, just opening works with the IR signal so its past the door control.

So problems as follows.

No 3 flashes
Interior light stays on an age, UNLESS you turn on the engine and drive off, it then is normal.
No connivence closing.
You cannot open the front doors from the dash.
The dash button has 2 red led's only the rear it lit.

Well spent a few hours on this today, fitted new drivers door latch £62 from MB.
No change.
Fitted new door controllers both sides, No change.
Checked continuity of the canbus both wires back the the distribution block drivers side and all good, so wires across the A post are good and double checked.


So last thing to look at is the SAM but I cannot see it being that at fault as it flashes open.
I am thinking a coding clash or a bug coding in a module if that's possible.
Question is when scn coding take place is it automatically looking at all the modules or does it stack them up and could give a clash, and better still could it be over come by re setting all thats been done?
 
OP
OP
zenman63

zenman63

MB Enthusiast
SUPPORTER
Joined
Feb 8, 2010
Messages
2,258
Location
Warwickshire
Car
172 Slk 250 & Porsche 911 991.2 S Cayman S
So I take it even the pros cannot help?

I will swap the sam for a known good one to test.
Failing that it must be a coding issue.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom