Crank Sensor Replacement (A140 W168)

TazzyK

New Member
Joined
Sep 25, 2013
Messages
15
Car
A140 Avantgarde
I need to replace the crank sensor on our old Mercedes A140 (W168).

I managed to get the old sensor out (just about) but destroyed it in the process as it was a VERY, VERY tight fit. Now I can't get the new one in as again, it's a VERY, VERY tight fit.

I don't know much about these sensors as such, so I guess I'm asking if I can safely use any sort of lubrication to aid fitting? There's not much space (even though the sensor is on the front face near the gearbox, access is awkward). If anyone has done this on this particular model (or any other as the same sensor fits other models too) can you please advice on how to go about refitting
 

Auto-mobile

MB Enthusiast
Joined
Oct 1, 2011
Messages
1,600
Location
Birmingham
Car
2x c43 Amg clio 172 turbo 314bhp
Run some sandpaper around where the sensor sits then smear a small amount of grease around the sensor, not on the end though.
 
OP
OP
T

TazzyK

New Member
Joined
Sep 25, 2013
Messages
15
Car
A140 Avantgarde
Thanks for the reply. Sorted now but my hands are aching and finger tips are well and truly cut!!

I cleaned out the hole it sits it with some brake cleaner and 1000 wet n dry paper. Also, the sensor itself had a slight lip (where the two plastic halves joined together???) and I flatted these out with the sandpaper. It wasn't much, but it was possible to force most of the sensor in to be able to get the torx screw on. Then I drove the rest of the sensor home by tightening the screw. If it fails again I feel sorry for the next person having to take it out (in another 150k miles lol)
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom