Do I need replacement spark plugs

Discussion in 'AMG Lounge' started by Gledsyc63, Nov 20, 2016.

  1. Gledsyc63

    Gledsyc63 Hardcore MB Enthusiast

    Messages:
    140
    Joined:
    Jul 20, 2014
    Location:
    Halifax
    Car:
    2012 c63 amg 14 amarok canyon
    ive been having some problems with the car seeming like it misfires when driving or the rev needle jumping up and down a couple hundred revs sometimes.

    I have full ipe Bmc filters and eurocharged v5 map car is running around 550. I'm running Mercedes spark plugs ngk I think. Are these the right temperature rating for the power I'm running? If anybody would be able to help.

    So far I've had jerry update my map on the dyno day, john from bft reset All my cam timings.
    Gearbox update fuel pump update and esp update I've tried different maf sensors still no change.
    And still the problem persists. Just trying to rule out all options if anyone can help

    Thanks
     
  2. DSB SL AMG

    DSB SL AMG Hardcore MB Enthusiast

    Messages:
    1,599
    Joined:
    Jan 28, 2010
    Location:
    Cheshire
    Car:
    300SL (R129 1992 pre-facelift), Volvo V70 SE D5 Auto Geartronic
    Have you had the car plugged into STAR to get the DTC's read? when was the car last serviced?, how many miles have the plugs done?

     
  3. markjay

    markjay MB Club Veteran

    Messages:
    18,759
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk

    A Part Number or Model Number for the plugs you are currently using would help.... there is more than one model of MB-Branded NGK plugs.
     
  4. Lee C63

    Lee C63 Hardcore MB Enthusiast

    Messages:
    1,517
    Joined:
    Apr 20, 2013
    Location:
    Newcastle
    Car:
    C63 (weistec supercharged)
    I run standard MB plugs on mine and it's fine,

    I did have a issue with a misfire last year which turned out to be a faulty fuel injector. However this caused a CEL.

    Another possible problem if it's just a slight misfire is the spark plug gap needs checking....again had this happen to me
     
  5. OP
    OP
    Gledsyc63

    Gledsyc63 Hardcore MB Enthusiast

    Messages:
    140
    Joined:
    Jul 20, 2014
    Location:
    Halifax
    Car:
    2012 c63 amg 14 amarok canyon
    Yes had the car plugged into star last Thursday at my local msl no fault codes, raja is also helping me with the problem. In march this year and done 2600 miles on the plugs.

    Part number for plugs is 004 159 39 03

    Will check them when the car gets garaged for winter. Only other options are if that doesn't work is I will try have the trans oils done again. And trying to avoid this but have the engine software updated them have to get the car remapped using the new engine software.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.