Driver side Xenon not working MB part or Hella?

Page may contain affiliate links. Please see terms for details.

DSM10000

Hardcore MB Enthusiast
SUPPORTER
Joined
Jul 12, 2011
Messages
13,857
Location
Near Salisbury
Car
MX5 1.8 Sport, Range Rover 5.0 SC, BMW X1
I changed the Xenon bulb in my 2008 W211 last week because it had failed according to the cluster display message.

The replacement(Osram) lasted 2 days so I scanned for faults with my iCarsoft MB 2.0 unit and on checking the headlight voltages I had - 4v and +97v for the passenger side "transformer" and on the drivers side had - 4v and 0v.

I assume that the high voltage part for the HID bulb has failed as there are no fuses that I can find that relate to headlamps.

Would anyone know the part number for the replacement part?

The MOT is due in 3 weeks and I would like to get it fixed ASAP. Also, is it an easy part to get at to replace?

Many thanks 😁
 
I assume that the high voltage part for the HID bulb has failed as there are no fuses that I can find that relate to headlamps.
I assume you mean you need a new ballast? Are you sure it’s not just showing 0V as the bulb has failed again out of coincidence? Perhaps a faulty bulb?
 
I assume you mean you need a new ballast? Are you sure it’s not just showing 0V as the bulb has failed again out of coincidence? Perhaps a faulty bulb?
Bulb was brand new and works in the other headlamp
ICarsoft referred to the part as a "transformer" I I presume the Ballast is also responsible for generating the high voltage?
 
Bulb was brand new and works in the other headlamp
ICarsoft referred to the part as a "transformer" I I presume the Ballast is also responsible for generating the high voltage?
You could try and move the ballast from the other side over?
 
I was sent the above image and part numbers regarding the problem I am having with the drivers side Xenon and have been informed that there are 2 control units involved.

As icarsoft showed what it referred to as a "transformer" showing no voltage output would anyone know if both units are required?

The car has a version of the intelligent lighting system.

TIA
 

Users who are viewing this thread

Back
Top Bottom