E-Class -COMAND not working properly after windscreen replaced

Discussion in 'Electronics' started by EnEm, Aug 11, 2017.

  1. EnEm

    EnEm New Member

    Messages:
    27
    Joined:
    Aug 17, 2016
    Car:
    E-Class W213
    I don't know if anyone can shed any light on this problem with W213 widescreen COMAND. Windscreen had a crack and was replaced by MB main Dealer (at cost of nearly £700).

    After this, the COMAND is not fully working - after entering a destination the time does not count down as you drive to the destination, the middle navigation display (in front of the driver between the dials) is frozen on the first road that you depart from and the blue route is not updated properly. The triangle that shows the vehicle position does correctly locate at the position of the car. Not tested if the voice instructions work properly.

    It is under warranty so it is not too relevant whether the process of replacing the window broke the sat nav or if it is just a coincidence (the dealer has instinctively denied responsibility). Date for workshop is two weeks away, so if anyone has any ideas or if there is a user re-set that I can do in the meantime this would be appreciated.

    Has anyone else seen this problem? Any thoughts or comments welcome.

    EnEm
     
    Last edited: Aug 11, 2017
  2. Rowanlaw

    Rowanlaw Member

    Messages:
    37
    Joined:
    Jan 10, 2017
    Location:
    Scottish Borders
    Car:
    S213
    Hi EnEm, What you describe matches my experience with COMAND sat nav on S213 which was only rectified when the dealer replaced the GPS receiver in the wing mirror.
     
  3. OP
    OP
    EnEm

    EnEm New Member

    Messages:
    27
    Joined:
    Aug 17, 2016
    Car:
    E-Class W213
    OK. Thanks for the feedback. Have now realised that the speed limit recognition isn't working either - it seems to work, but this only based on sat nav data, not the camera.

    EnEm
     
  4. markjay

    markjay MB Club Veteran

    Messages:
    16,994
    Joined:
    Jun 24, 2008
    Location:
    London
    Car:
    W204 C180 Executive SE 2013 Automatic / COMAND NTG4.7 and Morel speakers fitted by www.comand.co.uk
    The speed sign recognition camera is attached to the windscreen (just under the rear view mirror) and I have been told that replacing either the windscreen or the camera requires a recalibration process afterwards.

    So it seems that at the very least there's an issue with the camera/windscreen (possibly calibration issue) following the windscreen replacement, and I suggest that you take the car back to the dealer to get that sorted first.

    Whether this will also resolve the other issues with COMAND I do not know, but it might - and at any rate it's worth raising these with the dealer as well when you book your car in.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.