e320 cdi crank but wont start

Discussion in 'Engine' started by alanm999, May 9, 2015.

  1. alanm999

    alanm999 New Member

    Messages:
    28
    Joined:
    Jan 26, 2014
    Location:
    sheffield
    Car:
    2003 e320 cdi 210
    hi in need of help anyone got any ideas 2003 e320 w210 cdi estate
    brief summary did about 80 miles no problems parked up for 10 mins came to start but car cranks but will not start turns over ok but nothing 1/2 tank of diesel

    left it overnight but still no joy cranked till battery flat
    i replaced o rings on fuel lines about 4 months ago
    ive checked connections on injectors seem ok cant see any air bubbles in pipes
    any advice appreciated
     
  2. streethawk

    streethawk Hardcore MB Enthusiast

    Messages:
    1,018
    Joined:
    Jun 27, 2011
    Location:
    leicester
    Car:
    E320cdi sport
    Might be crank position sensor
     
  3. m2287

    m2287 Hardcore MB Enthusiast

    Messages:
    3,053
    Joined:
    Jan 27, 2010
    Location:
    cambridge
    Car:
    Bentley Continental GT
    From a similar experience, see if it starts and runs using easy start...
     
  4. bob6600

    bob6600 MB Club Veteran

    Messages:
    5,572
    Joined:
    Jan 3, 2013
    Car:
    AUDI S8 V10, S210 E320 CDI (R.I.P.)
    +1

    Sounds very much like the CPS
     
  5. Theothers

    Theothers Active Member

    Messages:
    94
    Joined:
    Dec 28, 2006
    Location:
    Kent
    Car:
    SLK350, C320CDI, Fiat 500c (soon to be gone!) and Smart Roadster, plus a Fireblade :-)
    Got to agree CPS. I had the same thing with my Smart Roadster.
     
  6. OP
    OP
    alanm999

    alanm999 New Member

    Messages:
    28
    Joined:
    Jan 26, 2014
    Location:
    sheffield
    Car:
    2003 e320 cdi 210
    hi all thanks for imput got it to start this morning after i checked bleed off
    still not right though as it is taking about 5 to 10 seconds of cranking before it starts
    do you think that it could still be cps or more likely fuel related?
     
  7. OP
    OP
    alanm999

    alanm999 New Member

    Messages:
    28
    Joined:
    Jan 26, 2014
    Location:
    sheffield
    Car:
    2003 e320 cdi 210
    hi update been trying to start for last hour eventually fired up again but now i have abs bas esp lights on visit workshop
    anyone got any ideas
    thanks
     
  8. bob6600

    bob6600 MB Club Veteran

    Messages:
    5,572
    Joined:
    Jan 3, 2013
    Car:
    AUDI S8 V10, S210 E320 CDI (R.I.P.)
    Did you flatten the battery? If so steering full left lock, full right lock and then back to centre position should sort it
     
  9. E270 Owner

    E270 Owner Hardcore MB Enthusiast

    Messages:
    1,672
    Joined:
    Dec 23, 2012
    Location:
    S E London
    Car:
    Anything I get my hands on.
    Whats this mean ?

    MB Star session will save you £££'s of guesswork.

    :thumb:
     
    1 person likes this.
  10. themorg

    themorg New Member

    Messages:
    6
    Joined:
    Jan 22, 2015
    Car:
    e220 estate cdi
    hiya pal
    had the same problem with my e220,(same fuel system set up) after lots of f---ing about with o rings,filter housing,pumps etc i did a spill of test and found 2 injectors not spilling of properly, i changed the 2 faulty ones and she fired up after a couple of turns,running like a dream now,as for the abs bas and esp lights they will come on when the battery goes down ,give it a run and they will go off, hope this helps
     
  11. bob6600

    bob6600 MB Club Veteran

    Messages:
    5,572
    Joined:
    Jan 3, 2013
    Car:
    AUDI S8 V10, S210 E320 CDI (R.I.P.)
    After a flat battery/disconnection you need to turn the steering lock to lock and back to centre to clear the BAS etc faults
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.