E320 CDI gearbox stuck in one gear!!!

Discussion in 'Engine' started by walesuk1, Oct 30, 2008.

  1. walesuk1

    walesuk1 New Member

    Messages:
    21
    Joined:
    Jan 21, 2008
    Hi got a 2002 e320 cdi 120,000 mls full service history,been getting a strange sound on startup from cold as if starter motor is hitting then missing (grinding sound).thought maybe it was battery but its not.Drove to my dads earlier,then driving back car wont change out of gear tiptronic not working.Tried turning off and on wont reset itself ,just wont change gear.no warning lights on either.Dash lights seem to be staying on aswell after key is removed.any ideas guys?

    regards
    Mike
     
  2. Voyager

    Voyager Hardcore MB Enthusiast

    Messages:
    123
    Joined:
    Oct 31, 2008
    I have same / similar problem

    My E320 CDi estate was fine last night, when I drove it this morning, the auto box was permamtantly in second gear - no warning lamps on the dashboard or no audiable clunks when selecting drive. The car has done 39,000 miles and is in excellent condition.
     
  3. OP
    OP
    walesuk1

    walesuk1 New Member

    Messages:
    21
    Joined:
    Jan 21, 2008
    same here no warnings, but mine does seem to clunk and lurch when selecting drive,can only drive in one gear maybe second at 40 mph tops!!
     
  4. OP
    OP
    walesuk1

    walesuk1 New Member

    Messages:
    21
    Joined:
    Jan 21, 2008
    can only assume its in limp home mode?
     
  5. Buggerlugs

    Buggerlugs Hardcore MB Enthusiast

    Messages:
    142
    Joined:
    Sep 8, 2008
    Location:
    Barnsley, near Barbados.
    Car:
    Triumph Sprint RS
    Yep, sounds like limp home mode. You need to get it plugged in and get the trouble codes for a starting point.
     
  6. OP
    OP
    walesuk1

    walesuk1 New Member

    Messages:
    21
    Joined:
    Jan 21, 2008
    I see a few people have had similar problems and its ATF oil in the ECU working its way up the wiring loom had a look under the bonnet where the ECU is but Im not sure which one it is as there's a few ECU's there but cant see any oil in or around that part of the engine bay.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.