E350 (W207) sat nav showing incorrect current location

Discussion in 'Electronics' started by k44ssk, Apr 28, 2014.

  1. k44ssk

    k44ssk New Member

    Messages:
    1
    Joined:
    Apr 28, 2014
    Car:
    Mercedes E350 Convertible
    Hi guys,

    Hope you can help, I recently purchased a E350 from dealer and sat nav was working fine and a couple days later it started showing my current location as being 100 miles away!

    I went into engineering mode in COMAND and set it to my current location and started working fine and then a couple days later the 'arrow' kept moving but not in line with where I currently was.

    I changed the the current location again and now it is showing me to be in Denmark :doh:

    Please advise.
     
  2. st13phil

    st13phil MB Club Veteran

    Messages:
    6,307
    Joined:
    Nov 6, 2007
    Location:
    North Oxfordshire
    Car:
    His - Diamond White W212 E63 Biturbo with Night Package / Hers - Obsidian Black R172 SLK55
    Suggest you take it back to the supplying dealer and ask them to fix it.
     
  3. Alfie

    Alfie Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    7,253
    Joined:
    May 5, 2004
    Location:
    Surrey
    Car:
    W169 A class (loaded)
    Most likely a duff antenna. Take it back and ask them to fix it.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.