E43 AMG owners thread

Discussion in 'AMG Lounge' started by indus, Jan 28, 2018.

  1. indus

    indus Member

    Messages:
    49
    Joined:
    Jun 26, 2014
    Car:
    c63 AMG estate
    Hi
    I thought it might be useful having an owners thread for the E43. The car will have many things in common with other MB cars but somethings will be unique.

    I've had the car 48hrs now and have configured the individual dynamic select as follows

    1) Drive train = sports

    2) Steering = sports

    3) Suspension = sports +

    In other cars sports + for suspension is usually too harsh for UK roads and best suited to track. However in this car sports + seems perfect and still more comfortable than the ride in my c63 AMG.

    The problem I'm having is with the sports setting for drivetrain with the 9g gearbox. It seems to hang on to the gear for too long and not change up.

    Just because I'm in sport mode doesn't mean I want to rev to the redline. My c63 seemed to be able to sense this and change up but the e43 doesn't.

    For example, with drive train in sport mode I might give it some welly from a standing start at the lights but once I get to 40 mph I want to back off. The c63 would sense that I had backed off the throttle and change up but the e43 stays in the lower gear.

    Anybody else find this?

    Apart from this I'm really liking the car. In sport + suspension setting it really hustles, corners and changes direction so well for a big car whilst still retaining so much comfort.
     
  2. guhvies

    guhvies Active Member

    Messages:
    67
    Joined:
    Feb 21, 2015
    Car:
    2017 C43 AMG Saloon
    The 9g tronic needs to learn from you when to change gears. IOW, change up with the paddles when you want it to.
     
    indus likes this.
  3. OP
    OP
    indus

    indus Member

    Messages:
    49
    Joined:
    Jun 26, 2014
    Car:
    c63 AMG estate

    Are you saying that if I use the paddles to change up a gear the gearbox will learn and remember this 'behaviour' in full auto mode?

    Thanks
     
  4. Neiltodd

    Neiltodd Hardcore MB Enthusiast

    Messages:
    311
    Joined:
    Jul 22, 2009
    Location:
    moray
    Car:
    c63 amg estate
    I think that is what is supposed to happen
     
    indus likes this.
  5. OP
    OP
    indus

    indus Member

    Messages:
    49
    Joined:
    Jun 26, 2014
    Car:
    c63 AMG estate

    Thanks, will give that a go.
     
  6. guhvies

    guhvies Active Member

    Messages:
    67
    Joined:
    Feb 21, 2015
    Car:
    2017 C43 AMG Saloon
    @indus, yes. You need to 'train' it. It does take a while to adapt though
     
    indus likes this.
  7. OP
    OP
    indus

    indus Member

    Messages:
    49
    Joined:
    Jun 26, 2014
    Car:
    c63 AMG estate

    Thank you
     
  8. StuW213

    StuW213 Active Member

    Messages:
    62
    Joined:
    Apr 19, 2018
    Location:
    London
    Car:
    AMG E43
    Hi from another E43 owner. Had a lot of hassle with mine as you will see if you search other threads. Love it when I have it though. Will definitely be trying to train that gear change.
     
  9. StuW213

    StuW213 Active Member

    Messages:
    62
    Joined:
    Apr 19, 2018
    Location:
    London
    Car:
    AMG E43
    Btw anyone have any trouble with stop start? Does it work as you'd expect on most journeys after the car warms up? Mine NEVER activates except after a very long journey or a full charge and then works for one short journey.
     
  10. andreas_t

    andreas_t Member

    Messages:
    53
    Joined:
    Oct 5, 2005
    Location:
    Kenilworth
    Car:
    E43AMG
    Yes, mine does the same. It looks like the battery seldom stays at full charge - and the stop/start doesn't kick in as a consequence.
    Thought it was the winter weather - but it still does it now it's (much ?) warmer.
    I put mine on a charger and it took a good 4 or 5 hours to fully charge - and then it was on 'not fully charged' within a couple of days. The start/stop 'feature' followed the battery charge trend.

    I plan to give the battery a 'recon' - my charger has a program for that - and see if the performance improves.

    PS. It's good to have this thread to compare experiences on the car's 'features'. Keep them coming
     
  11. StuW213

    StuW213 Active Member

    Messages:
    62
    Joined:
    Apr 19, 2018
    Location:
    London
    Car:
    AMG E43
    Ah bad luck! Mine took a number of hours to charge also. I have the ctek mxs 5 charger which also has a recon mode. It also has AGM mode too but I am unsure as to whether the battery fitted is AGM or normal. Both recon and AGM mode charge at a higher voltage and the manual says to use only 14 point something voltage charger so i was wary of doing either, AGM and recon charge at 15.6 i believe.
     
  12. StuW213

    StuW213 Active Member

    Messages:
    62
    Joined:
    Apr 19, 2018
    Location:
    London
    Car:
    AMG E43
    Ps mine goes to partly charged after one short journey!
     
  13. StuW213

    StuW213 Active Member

    Messages:
    62
    Joined:
    Apr 19, 2018
    Location:
    London
    Car:
    AMG E43
    Did you buy it new or second hand and is it an early build? Mine was registered in January of 17. Thanks it's good to know I am not quite alone. There is at least one e43 owner who says it works normally for them.
     
  14. andreas_t

    andreas_t Member

    Messages:
    53
    Joined:
    Oct 5, 2005
    Location:
    Kenilworth
    Car:
    E43AMG
    Mine is May '18 build. From what I can gather, it was used for less than 2 months - then sat somewhere relatively dry and warm (static demonstrator ?) for 5 months.
    PS. I have the same CTEK as you.
     
  15. StuW213

    StuW213 Active Member

    Messages:
    62
    Joined:
    Apr 19, 2018
    Location:
    London
    Car:
    AMG E43
    Ah well mine was very low mileage and I suspect therefore left for a period too. Somebody said that the manual says permanent damage is done to the battery if left for longer than 6 weeks. What setting do you use on the ctek?
     
    Last edited: Jun 15, 2018 at 4:08 PM
  16. andreas_t

    andreas_t Member

    Messages:
    53
    Joined:
    Oct 5, 2005
    Location:
    Kenilworth
    Car:
    E43AMG
    If it'spermanently damaged, then it will show up within the warranty - I have no doubts about that: just wait for the winter and it will rear its ugly head.
    In as far as the CTEK is concerned, I have only charged in 'normal' mode - I don't believe in higher voltage charging as I think it affects the battery life anyway.

    I'll let you know when I do the 'recon' - and if anything positive comes of it.
     
  17. StuW213

    StuW213 Active Member

    Messages:
    62
    Joined:
    Apr 19, 2018
    Location:
    London
    Car:
    AMG E43
    Just taken mine in again this morning. I said I thought it had been damaged before I took ownership and he said that won't be covered under warranty however it will be covered as a problem within the first six months of purchase and therefore covered by the sales department. The recon mode I think uses a higher voltage, didn't know if you used the AGM mode but pretty sure the battery in mine is not an AGM one as I've heard it venting during charge (I Just use the non AGM car mode myself).
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.