engine cut out during driving

Discussion in 'Engine' started by Braincrank, Nov 16, 2016.

  1. Braincrank

    Braincrank Hardcore MB Enthusiast

    Messages:
    360
    Joined:
    Sep 12, 2012
    Location:
    West London
    Car:
    Mercedes 200E
    Hello all .
    Got a bit of a problem with the old tank.
    The missus was driving today and suddenly without notice the engine cut out, dead as a dodo, and all the dashboard lights are on.
    She switched the ignition off and rolled to the side of the road. (without power steering) .
    Then apparently she cursed and swore and turned the ignition key and the engine started again without any hassle.
    She carried on with her journey to her work without any more hick-ups. The car was then standing for about 6hrs before she drove back home without any problems.
    Where do I start looking for the root of this incident ?
    The car is a 124, 200E, petrol, automatic
    Any hints or tips are greatly appreciated !
     
  2. OP
    OP
    Braincrank

    Braincrank Hardcore MB Enthusiast

    Messages:
    360
    Joined:
    Sep 12, 2012
    Location:
    West London
    Car:
    Mercedes 200E
    I think I'll start by checking the distributor and rotor arm tomorrow .....
    Any other ideas ??
     
  3. mbenz1

    mbenz1 Hardcore MB Enthusiast

    Messages:
    947
    Joined:
    Jul 27, 2010
    Car:
    '05 C220 CDI Avantgarde SE
    Fuel starvation? Maybe worth looking at the fuel pump and the plugs also as a guess.

    Sent from my GT-I9505 using MBClub UK
     
  4. stwat

    stwat Hardcore MB Enthusiast

    Messages:
    3,174
    Joined:
    Jun 20, 2004
    Location:
    Sheffield
    Car:
    1989 W126 300 SE
    A faulty OVP relay can cause this. The many heat cycles over the years can cause solder joints to dry and crack.
     
  5. OP
    OP
    Braincrank

    Braincrank Hardcore MB Enthusiast

    Messages:
    360
    Joined:
    Sep 12, 2012
    Location:
    West London
    Car:
    Mercedes 200E
    Fuel Pump is 2 years old and plugs 1month (last service) .
    Will check relay tomorrow.
    Thanks
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.