Engine diognostics???? Limp home mode

Discussion in 'Electronics' started by lukester2002, Jul 4, 2011.

  1. lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Hi there

    I have justed joined and I have just purchased my first Merc, but I have a problem that I hope you guys might be able to help me with.

    Its a mercedes c class c220 cdi 2002 automatic UK model 98,000 miles and the problem is that it keeps going into limp home mode and nothing shows up on my dash board. It does it quite a bit mainly when I accelerate fairly hard. and then it wont go above 3000rpm. It seems to run ok apart from this problem, so I assume it could be an electrical fault as it is not all the time. Any ideas guys im really worried that I have been ripped off, and it is such a shame as I have wanted one of these all my life and I want to keep it, I have just paid a local garage £150 to put in a new maf sensor and it has made no difference but he said the car needs to get used to it in about 40 miles, is this true? Is there anyone out there near Halifax, west yorkshire with the appropriate diognostics?

    Thanks

    [​IMG][​IMG][​IMG]
     
  2. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Hi All

    I posted earlier about engine diognostics???? just a thought, I putchased this car about a month ago and the problem with it going into limp home mode cannot be detected and does not show on the dash. One garage suggested changing the EGS.

    Is there a possibility that the previous owner could have bypassed the computer so the fault did not show?

    Would it be sensible to change the EGS, probably not going to be cheap but maybe my only option....

    Any help would be so much helpful

    thanks

    Luke
     
  3. carat 3.6

    carat 3.6 MB Enthusiast

    Messages:
    3,923
    Joined:
    May 11, 2011
    Location:
    Buckinghamshire, yuppie central 1985.
    Car:
    96 e300d, 88 w124 superturbodiesel, 90 bmw E30 v8, + "others"
    Hi Luke, and welcome to the forum :thumb:

    Have you had the car on a diagnostic machine? Did it show any faults?

    When you put the ignition on, do you see a red light that says "EDC" ? -Dose it go out when started?

    Will it rev freely standing still?

    On the top of the engine do you see "coal like" deposits around the injectors?

    I'm tempted to say it's the MAF sensor, as when they go wrong it dosent allways show a fault.
     
    Last edited: Jul 4, 2011
  4. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Hi

    Ive had it on two computers and one garage said they had the star version of the software, but niether of them could pick up the problem or any faults. but the garages gave me some suggestions, unfortunatly neither of the solutions worked. So far I have had the MAF sensor changed, EGR cleaned, VAC pipes checked, new fuel filter, Can of 10k boost and plenty of redex. Also no lights show up on the dash.

    Thanks
     
  5. carat 3.6

    carat 3.6 MB Enthusiast

    Messages:
    3,923
    Joined:
    May 11, 2011
    Location:
    Buckinghamshire, yuppie central 1985.
    Car:
    96 e300d, 88 w124 superturbodiesel, 90 bmw E30 v8, + "others"
    Dose the catalic coverter rattle when you bang it? -could be a ristriction in the exhaust.

    Any deposits around the injectors?
     
  6. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Hi again

    It seems ok around injectors, no light with EDC on,

    where is te cat positioned ill have a check

    thanks
     
  7. carat 3.6

    carat 3.6 MB Enthusiast

    Messages:
    3,923
    Joined:
    May 11, 2011
    Location:
    Buckinghamshire, yuppie central 1985.
    Car:
    96 e300d, 88 w124 superturbodiesel, 90 bmw E30 v8, + "others"

    I think it is the first box in the system.
     
  8. horgantrevor

    horgantrevor MB Enthusiast

    Messages:
    1,902
    Joined:
    Jan 14, 2011
    Car:
    w202 c43 & w210 E220 CDI estate w219 W221
    also when you start the ignition do you get a light saying EDC and it goes out

    maybe the bulb was removed by last owner as this is a common trick on older cars

    it may also be the bulb is blown

    pull out cluster and check
     
  9. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Thanks

    Good idea, ill have it checked, would the fault still show on the computer though if the bulb was out?

    thanks
     
  10. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    No light with edc at all. before or after.

    Thanks
     
  11. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    Get he codes read on a proper STAR device, there will be codes.
     
  12. jobela

    jobela Active Member

    Messages:
    126
    Joined:
    Sep 20, 2007
    Guys at the garage did not know what they were doing, or did not have the correct equipment. If they did, even if the fault was not present at the moment, there would be a menu with the "stored faults", which would be a good place to start from.

    I reckon being a 02 plate, it could have either a pneumatic-comanded or electornic-comanded turbo geometry (turbo is a Garret GT1852VK(...)). Since they said "vacuum lines checked", I would try a cleaning of the turbo's geometry or check for leaks on the exhaust colectors.
     
  13. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Should I go to the main dealer then do you think?

    thanks
     
  14. jobela

    jobela Active Member

    Messages:
    126
    Joined:
    Sep 20, 2007
    At least to someone with DAS in developper mode. Intercooler clogged, MAP sensor and intake air valve motor can also cause that symptom. DAS should give a clue, but bill should only include the price of the defective components.

    Maybe you get lucky and it's only a leak in a vacuum line (example, the one that comands the turbo's geometry).

    Some dealers also don't know what they are doing...
     
  15. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Thanks

    What is DAS?

    If the faults have been cleared before I got the car would they still show?


    Thanks again
     
  16. jobela

    jobela Active Member

    Messages:
    126
    Joined:
    Sep 20, 2007
    DAS stands for Diagnosis Assistance System.

    The car will memoryze any fault that shows up in the car behaviour. Have you had your car reprogrammed?
     
  17. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    I havnt had it reprogrammed, but one garage did suggest changing the EGS.

    Do you think it is best I find a another garage with the star software? before having anymore work done?

    Thanks
     
  18. jobela

    jobela Active Member

    Messages:
    126
    Joined:
    Sep 20, 2007
    Yes.

    Also check on the net for "autogearbox reset" and do it. won't do no harm, and it should be around here. That is a reset to the autogearbox.
     
  19. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    Hi

    Just had it in the garage today and many faults are showing as stored but one stands out as it is stored and current it reads

    Component N15/3 (ETC control module) is faulty

    any ideas guys as the garage was not sure

    Thanks
     
  20. OP
    OP
    lukester2002

    lukester2002 Member

    Messages:
    38
    Joined:
    Jul 4, 2011
    Location:
    Halifax, West Yorkshire. England
    Car:
    Mercedes-Benz C220 CDI type 203 Classic Diesel
    P2001 NOx Trap Efficiency Below Threshold (Bank 2)

    I found this as one of the codes but I dont have a clue what it means

    Thanks
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.