Engine Noise caused battery drained S320

Discussion in 'Engine' started by stupiddoc, Apr 27, 2014.

  1. stupiddoc

    stupiddoc New Member

    Messages:
    10
    Joined:
    Jul 10, 2011
    Car:
    MB S320
    Hi expert champs need pearls of wisdom

    Got S320 (year 2000) turned off engine and heard noise like vaccum from engine - kept on coming even after 20 min
    started engine for 2 min and turned off brought down the noise but very minute amount of humming still coming

    1- radiator fan was not moving
    2- Air con recently refilled and used everyday
    3- Temp gage within normal limits

    When I opened bonet - felt the black plastic hood quite warm and slight burning smell

    Anyway went to bed and in Morning found battery flat ( Bosch batter replaced 3 months ago)

    All this is new onset
    Any suggestions please
     
  2. miro

    miro Hardcore MB Enthusiast

    Messages:
    3,444
    Joined:
    Mar 1, 2004
    Location:
    Sydney NSW Australia
    Car:
    W203 slightly modified
    Might be related to the viscous coupling at the fan or engine control unit.
     
  3. OP
    OP
    stupiddoc

    stupiddoc New Member

    Messages:
    10
    Joined:
    Jul 10, 2011
    Car:
    MB S320
    Well its seemslike after dead battery my soft closing and air suction for locks doors and boot not working. No hissing sounds anywhere

    Any ideas what I do to rectify this please

    Thanks
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.