engine not reving past 3000revs on W210 E 320 cdi

Page may contain affiliate links. Please see terms for details.

djw

New Member
Joined
Oct 28, 2010
Messages
23
Location
Cornwall
Car
S500l
Went out in my today W210 E320 CDI no problem, entered dual carrageway floored it but it just gradually increased in speed (no kickdown) max 3000revs. There was no lights on in dash or malfunction, pulled over to investigate and noticed when reving engine from under bonnet the waste gate linkage wasnt moving, tried reving a few more times and it cleared noticed wastegate linkage moving and you could hear it boost. Got to destination with no more problems after 30 mins i departed for home yep problem was back car changed up gears ok but no boost or kickdown and on dual carrageway it would cruise ok at speed but no fast acceleration. got back home and checked under bonnet same problem as before got it to clear but it came back again still no fault showing or light on in dash. Disconnected Maf sensor and started car didnt make any difference still no light or fault and car wouldnt rev past 3000 revs cleaned it all up and put back on car worked fine car went great but when i went back to car 20 mins problem was back. Has anyone had the same problem and am i right in thinking it is the maf sensor.:dk:
 
Is this an easy fix and is it expensive. When car is switched of you can push the wastegate linkage and it springs back ok. I did notice though when the car doesn't rev passed 3000 and you switch engine off you can hear a strange noise from that area for a few seconds but when the car is working ok you can't.
 
Cheers john, had similar problem before on a Vectra DTi and it was the MAF sensor but the engine management light came on thats why it was throwing me a bit as I dont have any lights or malfunction warnings this time but symptoms are identical. Will try new MAF sensor and let you know.
 
Check to see if the waste gate pivot has come off the motor arm. If it's has then you can try to re attach it but if it won't stop together you will need a new inlet manifold. It's a right pig as the part that wears is a small plastic socket but it only comes as part of the manifold

Fingers crossed that it has just come undone

Steve
 
Thanks to all for suggestions. Car worked great this morning no problems but after a few hours started to play up again. Managed to get it booked in straight away for diagnostics, cleared all old codes and faults and took car for a run and it ran like a brand new car loads of power,hooked it back up to computer no faults found when checked again, as i left the garage it started so we hooked it back up and its the EGR valve thats sticking, so looking for an EGR valve and maybe the solinoid next to the washer bottle too. Does anyone know how expensive the valve is heard from some about £130 and some say £350
 
Hi Guys, had similar problem few years ago, turned out to be an inlet manifold valve, MB main agent highwaymen would not sell the valve on its own but wanted to sell a complete inlet manifold at lots of £££'s.
Found a local guy who remanufactured the valve from a substance called polypenko (high temp resin) had manifold rebuilt with part, fantatsic all works great, power came back no problems.
Good luck djw.
 
Last edited:
Hi Guys, had similar problem few years ago, turned out to be an inlet manifold valve, MB main agent highwaymen would not sell the valve on its own but wanted to sell a complete inlet manifold at lots of £££'s.
Found a local guy who remanufactured the valve from a substance called polypenko (high temp resin) had manifold rebuilt with part, fantatsic all works great, power came back no problems.
Good luck djw.
HI Chris, could you give me contact details for the guy who remanufactured that valve for you. Has it stood up since it was fitted to now? Many thanks
 
Thanks to all for suggestions. Car worked great this morning no problems but after a few hours started to play up again. Managed to get it booked in straight away for diagnostics, cleared all old codes and faults and took car for a run and it ran like a brand new car loads of power,hooked it back up to computer no faults found when checked again, as i left the garage it started so we hooked it back up and its the EGR valve thats sticking, so looking for an EGR valve and maybe the solinoid next to the washer bottle too. Does anyone know how expensive the valve is heard from some about £130 and some say £350


Exactly the same problem on our W245. New EGR at main dealer was 146 after a little bit of goodwill....

D.
 

Users who are viewing this thread

Back
Top Bottom