Error code is "Turn signal left mirror"

Page may contain affiliate links. Please see terms for details.

bbrinkw

New Member
Joined
Jun 16, 2013
Messages
8
Car
was c class 2.5td. Now E320cdi 2004
C180 komp w203 2007 petrol
LHS door mirror indicator doesnt work. Even when hazard warning lights are on, too. The indicator lamp is functional (tested with rhs ok).
Does this mean there is a break in the wire. I've had a look but wires look okay (of what I can see when mirror cover is removed). I was getting a multi-meter volt reading, so totally confused.

Also, I have been looking unsuccessfully for a switch relay. Is there one?
 
I should add that when the indicator lever is pressed down ( to indicate left) the arrow light on the control panel is fast repeating.
 
I must have repaired various wires in our A Class mirrors two or three times each side and the left is getting intermittent again. Wires are too stiff and very badly routed from the factory.
 
I had the wires repaired on my W203 twice, while I had the car. That would be the most likely culprit. The break can be internal which means that the outer insulation looks just fine.
 
Yes.....mine were always broken internally with no damage to insulation........its obvious which ones are broken when you bend them though. My wife's habit of folding the mirrors in EVERY time she parks only makes the situation worse!
 
Yep as above typically the wiring fractures eventually due to fatigue when the mirrors are repeatedly folded/unfolded. I had this fixed under the Approved Used warranty on our 203.

I would guess (hope?) that later cars like our current 205 which fold the mirrors by default use slip rings or similar rather than wires bending back & forward ....
 
Yes.....mine were always broken internally with no damage to insulation........its obvious which ones are broken when you bend them though. My wife's habit of folding the mirrors in EVERY time she parks only makes the situation worse!
Thanks everyone for taking time to reply to my door mirror indicator fault. So it's more than likely there ia a break in the wire.
Can anyone tell me if the wiring goes from the mirror straight through the door or does the wiring go to a connection behind the door panel?
 
Connection in door panel.....but you don't have to remove the door panel....at least you don't on the A class.....there is a piece of trim that removes to reveal the plug up near the mirror on the inside.
 
Connection in door panel.....but you don't have to remove the door panel....at least you don't on the A class.....there is a piece of trim that removes to reveal the plug up near the mirror on the inside.
What a quick reply. Marvellous.
My car is a C class C180 komp 2007 so maybe doesnt have that "piece of trim". I've had a look at the door panel and removed the very top piece of trim hiding a speaker but no connection there except the harness wiring coming from the mirror. There is a large trim at the bottom of the door hiding the bigger speaker. I'm a bit scaredy pants to remove this unless I know for a fact that the mirror connection is behind this.
 
You can obviously replace the entire loom, but you can also find where the broken bit is 'by feel', then cut open the wire and reconnect it and insulate it (all done inside the mirror housing).
 

Users who are viewing this thread

Back
Top Bottom