ESL problem

jasons

Active Member
SUPPORTER
Joined
Jun 21, 2010
Messages
88
Location
suffolk
Car
w204 c220 cdi sport
I have an intermittent problem with the ESL it doesn't always make the noise when putting the key in sometimes I have to try it 2 or 3 times and sometimes it works if I leave the key in then after about 5 seconds I get the noise,as I said its intermittent I have video'd it when it didn't work,its got an approved used warranty and is booked in with my local dealer in October to be looked at but sods law will say it will work fine with them,do you think they will take my video as evidence of it not working properly or do you think they will have to experience the fault themselves,i am assuming it will only get worse and fail completely at some point.
 

Major774

MB Enthusiast
SUPPORTER
Joined
Sep 6, 2012
Messages
2,069
Location
Surrey
Car
W211 E55 AMG
No harm is showing them the video, it will help with their diagnostic. I suspect you just need a new ESL if the same happens to your spare key.
 
OP
OP
jasons

jasons

Active Member
SUPPORTER
Joined
Jun 21, 2010
Messages
88
Location
suffolk
Car
w204 c220 cdi sport
No harm is showing them the video, it will help with their diagnostic. I suspect you just need a new ESL if the same happens to your spare key.
I've not tried the spare key to be honest although looking at the condition of the key I would say this was the spare and the one I have as a spare was the main key from the previous owner.
 
OP
OP
jasons

jasons

Active Member
SUPPORTER
Joined
Jun 21, 2010
Messages
88
Location
suffolk
Car
w204 c220 cdi sport
just an update I had a new switch fitted under warranty in October and all was working fine but now the weather has turned a bit colder I am having issues again it was making the noise when I inserted the key and when removing the key now it doesn't make the noise when I insert the key but does when I turn the key and as soon as I turn the key off it makes the noise not on removal of the key the switch is working but acting differently what does everybody elses do ?
 

190

MB Enthusiast
Joined
Mar 4, 2015
Messages
3,796
Location
Cheshire
Car
2009 W204 C180K
First time I've heard of an ESL only operating when the key is turned but I suppose it's possible they have changed it's behaviour as an upgrade. Can't think how it helps though.

My W204 is 11 years old and yet to suffer the problem. What I do is try to minimise stress on the lock by always parking with the wheel straight ahead. You'll recall how that might help from the days of the old mechanical steering locks. I also minimise ESL operations by leaving the key in when it's parked in my garage. A ridiculous thing to do but there we are, it's what poor reputation of the ESL has brought me to.

If my ESL does fail I'll get a new motor and repair it myself. I'll then consider strapping the ESL out of the way so it doesn't engage the steering column which will give the new motor an easier time.
 

Users who are viewing this thread

Top Bottom