Esp bas light on 2003 ml

Discussion in 'Wheels, Tyres, Brakes & Suspension' started by ray1971, Sep 3, 2011.

  1. ray1971

    ray1971 New Member

    Messages:
    16
    Joined:
    Jun 26, 2011
    Car:
    ML270
    Hi guys,

    This is a follow up to my previous post back in July. My ESP BAS light on my dashboard is on and I have diagnostics carried out on STAR, and the following faults were reported -
    C114 steering angle sensor not initialized
    P0100 Hot film MAF Sensor
    P2001 ETC control module faulty

    The engineer also commented that my wheel alignment was out and recommended that I had the alignment corrected which I have had done today. I was hoping that having the wheels aligned would correct the light problem on the dashboard but it hasn't and the BAS ESP light is still on.
    What I am hoping for now is some advice as to what to do next with a view of spending the less amount of money to rectify the problem. I have turned the wheels left to right full lock three times but this has not corrected the problem. With the three faults as above in mind, what would be my next step to get this resolved? Any advice appreciated, I really want to get this problem cleared!!
    Thanks,
     
  2. Dichtung

    Dichtung Active Member

    Messages:
    290
    Joined:
    Oct 16, 2007
    Location:
    N.W.
    Car:
    W203 2.2Cdi
    My ESP light came on not too long ago because the wire connecting the pressure pad under the front passenger seat was breaking.

    Everytime someone uses that seat, the wire has to flex.

    Might be worth checking? :thumb:
     
  3. Dichtung

    Dichtung Active Member

    Messages:
    290
    Joined:
    Oct 16, 2007
    Location:
    N.W.
    Car:
    W203 2.2Cdi
    Forgot to add; Unplugging the pressure pad is the same as a broken wire, ie ESP light remains on.

    If this is your problem, and the pressure pad is a pig to get to, (and they usually are), then replicating the electrical resistance of the pressure pad will tell the ECU and the ESP light will go out.

    :thumb:
     
  4. OP
    OP
    ray1971

    ray1971 New Member

    Messages:
    16
    Joined:
    Jun 26, 2011
    Car:
    ML270
    Thanks for your reply. My light has been constantly on since my battery went flat and I re-charged it up. I think its probably the steering angle sensor....
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.