ESP problem

borz

Active Member
Joined
Jun 20, 2010
Messages
99
Location
Sussex
Car
C class 180k auto estate 57
Hi every one
Start the car this morning (ESP INOPERATIVE refere to the manual ) come up ? I notice the car is pulling to the right , appreciate any advice.thank you
 
OP
OP
borz

borz

Active Member
Joined
Jun 20, 2010
Messages
99
Location
Sussex
Car
C class 180k auto estate 57
Hi every one
Start the car this morning (ESP INOPERATIVE refere to the manual ) come up ? I notice the car is pulling to the right , appreciate any advice.thank you
Ps: I have searched the forum and could not find any one who had a massage saying refer to the car's manual!
 

2003-c180kcoupe

Active Member
Joined
May 30, 2011
Messages
123
Car
c180k coupe
Ps: I have searched the forum and could not find any one who had a massage saying refer to the car's manual!

i have a intermittent esp malfunction , usually say something like "esp warning take car to garage " ? or "esp not available" which resets itself as soon as i drive the car
 

tommy2

Active Member
Joined
Oct 27, 2010
Messages
60
I have had this problem, my car is a C180k 2002, I gathered info from here and there,and put it down to a sensor, which sits inside a box at the back of the boot. As I remember it I took the lid off the box found the component, unplugged it and sprayed it with switch cleaner. Now all of this may have been coincidence, but, nevertheless,I have not had the problem since
I suspect that there are many people on this forum,who are better equipped than me to help you.
 

2003-c180kcoupe

Active Member
Joined
May 30, 2011
Messages
123
Car
c180k coupe
I have had this problem, my car is a C180k 2002, I gathered info from here and there,and put it down to a sensor, which sits inside a box at the back of the boot. As I remember it I took the lid off the box found the component, unplugged it and sprayed it with switch cleaner. Now all of this may have been coincidence, but, nevertheless,I have not had the problem since
I suspect that there are many people on this forum,who are better equipped than me to help you.

had mine plugged into star at pcs , think olly said it was a speed sensor ? but wasn't worth replacing until it packs up altogether .
 
OP
OP
borz

borz

Active Member
Joined
Jun 20, 2010
Messages
99
Location
Sussex
Car
C class 180k auto estate 57
Could it be the traking or wheels balance? As the car is pulling to the right.
 

BlackC55

Authorised Forum Sponsor
SUPPORTER
Joined
Feb 8, 2007
Messages
19,796
Location
Portsmouth, Hampshire.
Car
E55K SL500 E250X2 Smart44 Brabus Track car E450Cabriolet X350 Pick up
The ESP fault I doubt will be related tp the pulling. Needs to go on a Star.
 
OP
OP
borz

borz

Active Member
Joined
Jun 20, 2010
Messages
99
Location
Sussex
Car
C class 180k auto estate 57
Yes I think I have to go on star to see what the exact fult is.
 

jefrs

Active Member
Joined
May 30, 2010
Messages
617
Location
Berkshire
Car
S210 E320 Avantgarde '98 full load
I keep having ESP/BAS/ADS/Anti-lock faults which trace to a loose connection to the ADS unit. You probably don't have Adaptive Damping (ADS), it "sits on top" of the ESP etc.

It occurs after the garage fiddles with the suspension. Just had bushes done, (again), tracking was done but now steering wheel off by 20º. This seems to upset it.

It will reset after restart. And I have re-seated the ADS (ECU) box, again. Which should fix it, again.

Turning the wheel from lock to lock will reset the parametric steering so it knows where centre is. If the car thinks it should be turning when you are going straight, the ESP will apply brakes.

But mine does not pull to the side! The ESP control the brakes and will do strange things if the geometry is out.

Has it been kerbed or hit a major pothole ?

STAR!
 
OP
OP
borz

borz

Active Member
Joined
Jun 20, 2010
Messages
99
Location
Sussex
Car
C class 180k auto estate 57
No I think it happend ofter I went over a speed bump,I will probably have the traking don first if that does not cure the problem it will have to be the sensor which have to be changed.
 

jefrs

Active Member
Joined
May 30, 2010
Messages
617
Location
Berkshire
Car
S210 E320 Avantgarde '98 full load
Hitting a big bump has been know to knock the ADS module loose on mine, that gives no end of idiot messages. I shall try securing it a little more firmly with some foam...

Also, I got rid of regular faults by servicing the earth points in the engine bay. The are three on mine, one under the air filter box - brown wires going to a bolt - clean and tighten.

Pulling to one side does sound like tracking, front or rear. This will throw up idiot messages from the ESP which thinks you want to be turning and will fight you. I was thinking reluctor sensors on mine but apparently not.

STAR will tell you where the faults originate but maybe not the underlying cause.
The fault may come from a reluctor but that does not mean the reluctor is faulty, it may be telling the truth.
 

Users who are viewing this thread

Top Bottom