External Temperature displaying 58 deg C !!!

jasohal

Active Member
Joined
Oct 21, 2004
Messages
223
Location
London
Car
S320 E500 E55
Help !!!

I have a E320 Coupe 1995 model.

On the LCD dash display below the speedo the gauge is suggesting it is 58 deg C.

Is this a simple case of faulty external temp sensor ?? where is this unit is it easy to replace ?? and any idea on price part no etc ??

Any ideas much appreciated.
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
jasohal said:
Help !!!

I have a E320 Coupe 1995 model.

On the LCD dash display below the speedo the gauge is suggesting it is 58 deg C.

Is this a simple case of faulty external temp sensor ?? where is this unit is it easy to replace ?? and any idea on price part no etc ??

Any ideas much appreciated.

Could be faulty could just be dirty. They are usually at the front of the car under the grill, or the skirt area. Try and find it and see if it is disconnected or dirty etc. Its cylindrical clipped somewhere.and will have a wire out the back.
 
OP
OP
jasohal

jasohal

Active Member
Joined
Oct 21, 2004
Messages
223
Location
London
Car
S320 E500 E55
Cheers...

I will look for it and let you know how I got on....
 

remus98

New Member
Joined
Mar 22, 2006
Messages
1
Did you find it? My temp shows 86c, I can see the sensor but can't get to the back to see if it is connected. C220CDi
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
remus98 said:
Did you find it? My temp shows 86c, I can see the sensor but can't get to the back to see if it is connected. C220CDi

Sounds as if yours has failed and wants renewing mate.:eek:
 

dubtaxi

New Member
Joined
Apr 7, 2006
Messages
3
Location
Dublin
Car
W210 Facelift E220 CDI, A140,
Mine(W210 E220 CDI) is also showing a constant 58 deg. I thought I had moved to Mars. anyone Know how to fix?
 
OP
OP
jasohal

jasohal

Active Member
Joined
Oct 21, 2004
Messages
223
Location
London
Car
S320 E500 E55
Simple - get it replaced.

Should be around £30 -40 from stealers..

I did and it fixed mine !!
 

fnkhan68

Active Member
Joined
Aug 22, 2005
Messages
646
Location
London
Car
1993 Mercedes 320e and 2000 BMW E39 523i
i too have a similar problem. on starting up my car the display shows 38c for about 3 seconds and then goes completly blank. any ideas?
 

Ian B Walker

MB Enthusiast
Joined
Jun 7, 2003
Messages
7,668
Location
Freckleton
Car
300-24, saloon and coupe, E300 24 valve diesel estate
On my E220 the temp display reads 10 degrees low all the time, the engine temp reads 50 - 60 and the speedo is 15mph out. I think its all to do with the resistor pack behind the instument cluster. If it is then i will let everyone know. failing that its new cluster time = £'s :crazy:
 

Brian WH

MB Enthusiast
Joined
Aug 21, 2002
Messages
6,283
Location
East Midlands
Car
JAGUAR XF 3.0D Premium Luxury
Ian B Walker said:
On my E220 the temp display reads 10 degrees low all the time, the engine temp reads 50 - 60 and the speedo is 15mph out. I think its all to do with the resistor pack behind the instument cluster. If it is then i will let everyone know. failing that its new cluster time = £'s :crazy:

Sounds logical to me.;)
 

Users who are viewing this thread

Top Bottom