Few issues with my 2009 Vito 109 compact

Ajsnell

New Member
Joined
Dec 19, 2020
Messages
2
Location
Kent
Car
Vito 109 compact
Hi all. I'm new to the forum
I've just bought a 2009 Vito 109cdi compact van
It's a bit of a fixer upper, a few issues are as follows:
- the rear doors don't lock, not even a noise when I press the lock button on the key, all others lock on the button
- the radio doesn't turn off when I turn the ignition off, it's a Sony CD player that's been put in
- the previous owner had those high-vis led lights put in which threw up a light error on the dash. I've switched it back to standard Halfords lamps but the error is still there

Does anyone have any advice on these issues please?

And on a little side note, the gears feel quite heavy/stiff when changing, my old Renault traffic gearbox felt light as a feather, is it normal for these Vito's to be a bit heavy into gears? It's hard to explain what I mean but it's a solid push into gear not just 2 fingers on the stick haha.
Thanks in advance
Alex
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,823
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S205 C300
Re. the doors, when you drive the van do you get any kind of 'door open' warning? There are spring-loaded pins on the sliding doors that contact pads on the back of the B pillar when closed - these can get dirty/tarnished/worn over time and give poor electrical contact (making the van think a door is open, in which case only the front two will lock). The other thing is to check the handbook ... I'm pretty sure there is a way to lock just the front doors (via the fob or one of the switches on the dash), which may have been activated accidentally.

IIRC the standard radio only goes off when you remove the key from the ignition.
 
OP
OP
A

Ajsnell

New Member
Joined
Dec 19, 2020
Messages
2
Location
Kent
Car
Vito 109 compact
Hey thanks for the reply
There is no door open light on, the sliding doors also lock as well as the cab doors, it's only the rear doors that don't lock. I will double check the radio! Thank you
 

BTB 500

MB Club Veteran
SUPPORTER
Joined
Aug 7, 2005
Messages
19,823
Location
Berkshire
Car
R129 SL500, W639 Vito 120, S205 C300
Hmm ok sounds like an issue with the lock itself on the rear doors then ... hope you manage to trace it.
 

Users who are viewing this thread

Top Bottom