Front Wiper Motor (B Class W246)

Page may contain affiliate links. Please see terms for details.

GSTAR1

New Member
Joined
Dec 14, 2019
Messages
4
Location
Manchester
Car
Mercedes Benz B Class
The front wiper motor on my B Class W246 (2013 B180 Diesel) appears to be wearing out. With the car in accessory mode, the wipers struggle to move. When the engine is running, the wipers don't move as fast as they used to, and I can hear a whirring noise as they move.

I followed a YouTube video first of all to remove the wiper assembly and re-grease the moving parts, in case it was due to insufficient lubrication. This did not make any difference, so to me this indicates a problem with the motor.

I've tried searching for a replacement motor, but to no avail. The part number on the existing motor is: A246 906 60 00. This is a Valeo part, but the only part I can find is for the back wiper motor: https://www.onlinecarparts.co.uk/ca...w242/59438/10234/motor-windscreen-wipers.html

I did get some quotes from 2nd hand parts retailers, the cheapest one I got was £210 which seems a bit steep and there's no knowing how long it will last. If indeed, it is actually the correct part to begin with.

A few questions:
  1. Can I safely assume it is actually the motor at fault here? Or is there anything else that could be causing this? Faulty fuse or wiring maybe?
  2. Is there any other compatible motor that I can use, if so which?
  3. Alternatively, is it possible to get the complete wiper assembly, including the motor?
Please see below pics of the wiper assembly and motor, let me know if you need any more information.

20211018_093236.jpg

20211018_094352.jpg
 
I guess you have tried lubricating all the linkages and maybe removed the drive cover and checked for free movement ?
 
Have you priced a genuine one?
 

Users who are viewing this thread

Back
Top Bottom