GLE electronic glitches

Page may contain affiliate links. Please see terms for details.

SPH1969

New Member
Joined
Sep 24, 2023
Messages
1
Location
Bordon
Car
GLE
Hi Guys ,
i got my 2016 GLE a couple of weeks ago and it has a lot of intermittent electronic glitches .
The first couple of occasions it will randomly flash up multiple system inoperative failures , every dash icon illuminates and speedo and rev counter fail ( even when driving ) however , no loss of power or physical functions . When turned off for a couple of hours seems to reset itself and all is good for a couple day . Today , did the same with the warnings but had actual loss in power steering .
Has anyone else experienced this

Thanks in advance
 
Hi Guys ,
i got my 2016 GLE a couple of weeks ago and it has a lot of intermittent electronic glitches .
The first couple of occasions it will randomly flash up multiple system inoperative failures , every dash icon illuminates and speedo and rev counter fail ( even when driving ) however , no loss of power or physical functions . When turned off for a couple of hours seems to reset itself and all is good for a couple day . Today , did the same with the warnings but had actual loss in power steering .
Has anyone else experienced this

Thanks in advance
If its not a battery with low voltage, (should be 12.6v+ fully charged), return the car to the dealer and get the fault fixed whilst its still under warranty. I'd put the battery on charge for a full 24hrs after checking voltage. No need to remove it from the car unless you park in the street.
You can check the state of voltage with a cheap multi meter (under £10 in Screwfix)
This should give you an idea on the state of your battery
68151.jpg
 
Hi Guys ,
i got my 2016 GLE a couple of weeks ago and it has a lot of intermittent electronic glitches .
The first couple of occasions it will randomly flash up multiple system inoperative failures , every dash icon illuminates and speedo and rev counter fail ( even when driving ) however , no loss of power or physical functions . When turned off for a couple of hours seems to reset itself and all is good for a couple day . Today , did the same with the warnings but had actual loss in power steering .
Has anyone else experienced this

Thanks in advance
Hope you didn't buy this one privately! As above, if you can, return it to the seller for repair/refund. I wouldn't be surprised if its electrics have been flooded.

Ernie
 

Users who are viewing this thread

Back
Top Bottom