GoPro Footage Of My 11.03@128mph At Santa Pod Saturday

Discussion in 'AMG Lounge' started by CraigWeistecC63, Sep 14, 2015.

  1. CraigWeistecC63

    CraigWeistecC63 Hardcore MB Enthusiast

    Messages:
    370
    Joined:
    Jan 27, 2014
    Car:
    769BHP Stage 3 Weistec C63
    9 people like this.
  2. merc85

    merc85 MB Club Veteran

    Messages:
    7,650
    Joined:
    Apr 23, 2013
    Location:
    Harwich
    Car:
    s211 e55k
    Absolutely Awesome :)
     
  3. MancMike

    MancMike New Member

    Messages:
    0
    Joined:
    Jul 29, 2014
    Not as fast as an RS7. ;)

    Seriously though, that sounds brutal. Cool to see the evo jump off the line a bit quicker, but then you just surge past.

    Will you run again soon when you get the slicks?
     
  4. OP
    OP
    CraigWeistecC63

    CraigWeistecC63 Hardcore MB Enthusiast

    Messages:
    370
    Joined:
    Jan 27, 2014
    Car:
    769BHP Stage 3 Weistec C63
    I was using launch control, so wasn't aiming for reaction times just wanted to get a good launch. I launched a lot better, will post an external vid later as have a couple I've been sent.

    I'm hoping to run the car again this year if I can get a slick set up, want to beat the UK record.
     
  5. OP
    OP
    CraigWeistecC63

    CraigWeistecC63 Hardcore MB Enthusiast

    Messages:
    370
    Joined:
    Jan 27, 2014
    Car:
    769BHP Stage 3 Weistec C63
  6. Grovsie31

    Grovsie31 Hardcore MB Enthusiast

    Messages:
    979
    Joined:
    Feb 3, 2015
    Location:
    Stafford
    Car:
    2009 335i DCT
    That sounds brutal. Love it.
     
  7. cazyp

    cazyp Hardcore MB Enthusiast

    Messages:
    266
    Joined:
    Oct 23, 2010
    Car:
    C43, Hilux
    Sounds great. Light was green for around 0.5 of a second before you moved!
     
  8. OP
    OP
    CraigWeistecC63

    CraigWeistecC63 Hardcore MB Enthusiast

    Messages:
    370
    Joined:
    Jan 27, 2014
    Car:
    769BHP Stage 3 Weistec C63
    Using launch control, the amount of times that's died on me when using or gone not available I wanted to make sure I nailed the start.

    Especially after queuing for hours.
     
  9. Shaunee

    Shaunee Active Member

    Messages:
    93
    Joined:
    Jan 26, 2015
    Car:
    A45 AMG
    To add, Craig achieved an awesome 1.7 (I think it was 1.77) 60ft time. That is amazing for RWD on road tyres and this much grunt. In comparison, I was running my modded A45 on the same day. Even with launch control AND 4Matic, I couldn't get my 60ft down below 1.87!! Clearly too much secret sauce! lol

    Craig,
    This was a fantastic time on road tyres and it was good to catch up on the day!

    Can't wait to see what you get with decent tyres on! ;)
     
  10. Cousy

    Cousy Hardcore MB Enthusiast

    Messages:
    158
    Joined:
    Sep 15, 2015
    Location:
    East Yorkshire
    Car:
    C63 AMG Coupé
    Shaunee, do you have any videos of your runs? What sort of times did you manage?
     
  11. acej

    acej Hardcore MB Enthusiast

    Messages:
    1,790
    Joined:
    Mar 22, 2012
    Location:
    Essex
    Car:
    ML350, AMG GT S
    Its getting better and better mate. Below 11 is on the cards.
     
  12. Shaunee

    Shaunee Active Member

    Messages:
    93
    Joined:
    Jan 26, 2015
    Car:
    A45 AMG
    Check out the details on my project thread... linked in my signature. :thumb:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.