Has the speedo illumination gone ? W220 W215

Discussion in 'Electronics' started by DSLiverpool, Feb 15, 2017.

  1. DSLiverpool

    DSLiverpool Hardcore MB Enthusiast

    Messages:
    1,556
    Joined:
    Sep 9, 2007
    Location:
    Wirral
    Car:
    Subaru Outback 3.0Rn
    Or is it the state of "on" the car is in - to me it looks like the neon ring behind it has gone ? anyone an idea of £ ? please[​IMG]
     
  2. Spin_bowler

    Spin_bowler Hardcore MB Enthusiast

    Messages:
    1,341
    Joined:
    Sep 1, 2006
    Location:
    Hertfordshire
    Car:
    LR Discovery, Audi A4 Avant, Smart For Two
    I had a W220 with the same cluster. IIRC the speedo didn't have the outline, it came on when using cruise or Speedtronic. It was a long time ago though.
     
    1 person likes this.
  3. m2287

    m2287 Hardcore MB Enthusiast

    Messages:
    3,053
    Joined:
    Jan 27, 2010
    Location:
    cambridge
    Car:
    Bentley Continental GT
    Lights/transistors are gone... around £150 to Repair. Lots of people on eBay who can do it.
     
    1 person likes this.
  4. OP
    OP
    DSLiverpool

    DSLiverpool Hardcore MB Enthusiast

    Messages:
    1,556
    Joined:
    Sep 9, 2007
    Location:
    Wirral
    Car:
    Subaru Outback 3.0Rn
    However - this is the another CL500 advertised elsewhere it has no rings in one shot and the rings ok in another ???

    [​IMG]

    [​IMG]
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.