Have i cooked my Navi system

Kentles

New Member
Joined
Mar 8, 2021
Messages
8
Location
minster on sea
Car
E220 CDI Avantgarde
Hi all
New Member here any advice much appreciated i recently bought a Mercedes E220 CD Auto 2010 model W212 i think, wanted to update the sat nav maps and bought an update disc set of 2 online from a place i had bought on before for a honda which worked perfectly, however after supposedly updating on disc 1 for 1 hr and 32% progress message came up unable to update maps ejecting disc consult car manual, now no sat nav at all just message to load disc 1 which i tried 2 or 3 times more but same results i need to know if i have cooked the hard drive or can i reset it somehow to revert to previous maps and settings.
Any help or advice would be appreciated.
Les.
 

OneForTheRoad

MB Enthusiast
Joined
Apr 20, 2015
Messages
3,911
Location
uk.
Car
2017 e350 c207 .. +65 ford kuga 2.0 cdi zetec awd..
Happened to me a whileback. I had to put the older version back on to get it going again.
 
OP
OP
Kentles

Kentles

New Member
Joined
Mar 8, 2021
Messages
8
Location
minster on sea
Car
E220 CDI Avantgarde
Happened to me a whileback. I had to put the older version back on to get it going again.
i would have tried that but dont have the original disc did not come with the car,
Thanks anyway .
 

Petrol Pete

MB Enthusiast
Joined
Nov 11, 2016
Messages
6,784
Location
Petrol stations ...everywhere
Car
C55 AMG Wagon
I am not 100% sure but I seem to remember someone on here saying that MB do not like doing nav upgrades because the car has to be live for absolutely ages and it ties up a service bay for too long to make it pay. I might have the wrong end of the stick , that might be for live updates and not from disk ones. But either way I would have thought the ignition must be on for the whole time of the download.

Someone with more info will be along soon. 👍
 
OP
OP
Kentles

Kentles

New Member
Joined
Mar 8, 2021
Messages
8
Location
minster on sea
Car
E220 CDI Avantgarde
I am not 100% sure but I seem to remember someone on here saying that MB do not like doing nav upgrades because the car has to be live for absolutely ages and it ties up a service bay for too long to make it pay. I might have the wrong end of the stick , that might be for live updates and not from disk ones. But either way I would have thought the ignition must be on for the whole time of the download.

Someone with more info will be along soon. 👍
Many thanks Pete.
 

Chrishazle

MB Enthusiast
Joined
Nov 13, 2008
Messages
4,529
Location
Nr Ashford, Kent
Car
2008 S204 C220CDI Elegance Estate Auto, 2008 R171 facelift SLK280 Auto.
Keeping the ignition on is to stop Comand shutting down, but OP had the engine running so no problem there. However, if the discs you were using were not genuine MB then that is the cause - there's many reports on the web of non-genuine discs causing update problems and possibly bricking Comand. Your best bet is comand.co.uk at Lightwater, Surrey, sponsors of this forum, have your VIN handy so they can look up the build sheet for your car, give them a call - and good luck! Maybe @Alfie and/or @richard (the owners of comand.co.uk) will pick up on this thread.
 

Tezz

Active Member
Joined
Mar 29, 2020
Messages
380
Location
loughton essex
Car
A180 w169 2006 2.0 cdi
Not sure what you have fitted, but in my case I was not worried about killing unit as I had already planed an android replacement

What I can tell you is I downloaded 5 versions of different updates from various sources and burned as per instrctions, tried update disc, one set off Ebay

Some worked, some did not, others look to work perfect till used for any lenght of time, a few overheated the unit

I did it as was curious, I came to conclusion it a big risk

But I fitted my android head unit, works perfect and no longer tied to mb, I'm now free to choxe from a multitude of free software and updates, perfect phone sync, hotspot, internet ect

Tezz
 
OP
OP
Kentles

Kentles

New Member
Joined
Mar 8, 2021
Messages
8
Location
minster on sea
Car
E220 CDI Avantgarde
Not sure what you have fitted, but in my case I was not worried about killing unit as I had already planed an android replacement

What I can tell you is I downloaded 5 versions of different updates from various sources and burned as per instrctions, tried update disc, one set off Ebay

Some worked, some did not, others look to work perfect till used for any lenght of time, a few overheated the unit

I did it as was curious, I came to conclusion it a big risk

But I fitted my android head unit, works perfect and no longer tied to mb, I'm now free to choxe from a multitude of free software and updates, perfect phone sync, hotspot, internet ect

Tezz
Thanks Tezz
i think the overheating of the unit was my problem, i had almost given up and was looking at an expensive repair i had left it alone for an hour or so whilst i went online for some ideas including this forum when i went back out i tried it once more and bugger me it started to update from where it previously left off, then asked to load the no 2 disc which it duly downloaded ok took an age to do it all 3 hours almost but it all seems there and hopefully it works not tried it on a destination guidance yet but it looks promising anyway.

cheers Les.
 

Alfie

Authorised Forum Sponsor
SUPPORTER
Joined
May 5, 2004
Messages
8,139
Location
Surrey/Cotswolds
Car
W169 A, W205 C, W451 smart
Thanks Tezz
i think the overheating of the unit was my problem, i had almost given up and was looking at an expensive repair i had left it alone for an hour or so whilst i went online for some ideas including this forum when i went back out i tried it once more and bugger me it started to update from where it previously left off, then asked to load the no 2 disc which it duly downloaded ok took an age to do it all 3 hours almost but it all seems there and hopefully it works not tried it on a destination guidance yet but it looks promising anyway.

cheers Les.
You were lucky. Many have had expensive repair bills as a result of using pirated disks.
 

Uky

Active Member
Joined
Jun 23, 2006
Messages
219
Car
C207
Updated the Comand APS NTG 4 in my C207 (M/Y 09-10) some years ago ( 2 x DVD's) . Turned OFF climate system (no fans running). Connected the 12V to an external PSU. The remaining systems in the car that was active took some 10 Amps while the update ran. First disk went fine. Second disk was som 50% or so, then returned "Read Error" and the disk ejected automatically. I then waited a few seconds and pushed the disk in again. This time the Comand read the second disk from where it left of. In the end all was OK.
 

wongl

MB Enthusiast
Joined
May 29, 2005
Messages
1,377
Location
Surrey and Hong Kong
Car
A180CDI, B200d, C300h, SLK250
Thanks Tezz
i think the overheating of the unit was my problem, i had almost given up and was looking at an expensive repair i had left it alone for an hour or so whilst i went online for some ideas including this forum when i went back out i tried it once more and bugger me it started to update from where it previously left off, then asked to load the no 2 disc which it duly downloaded ok took an age to do it all 3 hours almost but it all seems there and hopefully it works not tried it on a destination guidance yet but it looks promising anyway.

cheers Les.
Well done for your perseverance, and good that the unit completed its update. In my very limited experience, pirated discs will not start the update process on an NTG2.5 since the 'security track' is verified prior to the commencement of the update process.

Once the update starts it the NTG2.5 is quite robust with timeouts and restarts. I generally leave the update with a charger to the main battery. After 20 mins or so the unit will shut down, and I will simply restart it when I get a chance. I generally avoid leaving the engine running to avoid bashing the environment unnecessarily and bad for my pocket.

One time, like you, an update failed half-way thru disc 2, but I found restarting the update process with disc 1 worked, and it quickly resumed with disc 2 and completed the update process in under 10 mins or so.
 

Chrishazle

MB Enthusiast
Joined
Nov 13, 2008
Messages
4,529
Location
Nr Ashford, Kent
Car
2008 S204 C220CDI Elegance Estate Auto, 2008 R171 facelift SLK280 Auto.
I've done the NTG4 in my S204 a couple of times and the NTG2.5 in my SLK once, started the engine, connected charger to battery then turned engine off but left ignition on. Used genuine MB DVD's every time and had no problems, all updates installed without any hiccups.
 

Users who are viewing this thread

Top Bottom