Heating and Cooling

Discussion in 'Electronics' started by Crazyjester900, Sep 2, 2008.

  1. Crazyjester900

    Crazyjester900 Hardcore MB Enthusiast

    Messages:
    510
    Joined:
    Jul 25, 2008
    Location:
    Melbourne, Australia
    Car:
    C200 W202
    Hi guys,

    My A/C isn't very cold i am guessing that is because it needs to be re-gasses.
    No worries there but my heating only works on one side?

    My passenger side shoots out lovely warm air while my driver side just shoots out air, just the same temp as is out side?

    Thanks


    Brad :)
     
  2. andy27168

    andy27168 Hardcore MB Enthusiast

    Messages:
    4,324
    Joined:
    Nov 27, 2004
    Location:
    Southampton
    Car:
    1997 C230K, 1999 C43/55 AMG
    Hi,
    This will be due to a faulty duo valve, it is situated close to the master cylinder reservoir, with one water inlet hose and two hoses going into the vehicle.
    Take a look at this thread, it might fix you AC as well, because if the valves are not seating correctly they maybe letting a certain amount of hot coolant through to the heat exchangers.

    http://www.mbclub.co.uk/forums/showthread.php?t=26888
     
  3. OP
    OP
    Crazyjester900

    Crazyjester900 Hardcore MB Enthusiast

    Messages:
    510
    Joined:
    Jul 25, 2008
    Location:
    Melbourne, Australia
    Car:
    C200 W202
    Thank You
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.