Help needed fitting DRL's on E350 with Prior Design Kit

Discussion in 'Electronics' started by mmpaa, Aug 22, 2014.

  1. mmpaa

    mmpaa New Member

    Messages:
    10
    Joined:
    Jan 10, 2014
    Location:
    Cambridge
    Car:
    Mercedes E350
    Hi All,

    I'm new to this forum and was after a bit of advice, i recently bought my first Mercedes E350 coupe, i have also bought a Prior Design PD550 body kit from prior design Germany for the car as a project. With the kit i got some optional extra slim line Daytime running lights, now I'm not entirely sure on how to wire these lights.

    My car already has DRL's but with the PD550 front bumper i cannot use these lights as it just won't look right. The existing DRL are connected to 2 seperate ballasts and the new slim DRL's uses only 1 ballast.
    I could easily wire these to the existing connection using the exiting 2 ballasts without using the ones that came with the slim line DRL but wasn't too sure if this will work due to the correct voltage etc (this could in fact blow the LED's) so i would like to know if anyone has ever wired these lights before or know how to?

    I have tried contacting Prior design for some help/advise and to be honest the customer service i have been experiencing is very poor considering I have spent just over £2.5k with them.

    Anyway, i have attached pictures below of my new car and the Slim line DRL's along with the wiring diagram, I plan to have the whole kit complete by Sunday as long as i can get the DRL's working, any advice/help would be much appreciated,

    Slim line DRL wiring diagram (shows how to wire it to a car without existing DRL's)
    [​IMG]

    Image of the actual DRL's
    [​IMG]

    Image of inside of original bumper showing where the MB DRL's connect to
    [​IMG]

    Close up image
    [​IMG]

    The below image is the plug which connects to the image above.
    [​IMG]
     

    Attached Files:

  2. m2287

    m2287 MB Enthusiast

    Messages:
    3,078
    Joined:
    Jan 27, 2010
    Location:
    cambridge
    Car:
    Bentley Continental GT
    Pretty sure you were behind me on the a10 near Milton the other day.... Car looks NICE!!!

    And sorry but I can't help you, I'd say to leave the original wiring (maybe put resistors in to stop errors) and just make a new loom for the new DRL's...
     
    Last edited: Aug 22, 2014
  3. OP
    OP
    mmpaa

    mmpaa New Member

    Messages:
    10
    Joined:
    Jan 10, 2014
    Location:
    Cambridge
    Car:
    Mercedes E350
    Haha possibly, thanks mate im sure you will see me around in Cambridge area in the near future :)
     
  4. wywywywy

    wywywywy Active Member

    Messages:
    233
    Joined:
    Mar 20, 2013
    Location:
    NW UK
    Car:
    W221 S500 SWB (S65 AMG Style)
    I don't have an E Class or a Prior Design kit, but I think there are two ways to go -

    1. Discard the Prior wiring loom, then just adapt the connectors on the new DRLs to the OE connectors for the OE DRLs. May need to add resistors if they flash. They are not ballasts they are probably just resistors, and they are for sure 12v.

    2. Disconnect OE DRLs, put resistors on them and tuck them away. Then follow Prior's instructions for the new DRLs.

    Personally I'd go for option 1 first. Simplest.
     
    Last edited: Aug 22, 2014
  5. wywywywy

    wywywywy Active Member

    Messages:
    233
    Joined:
    Mar 20, 2013
    Location:
    NW UK
    Car:
    W221 S500 SWB (S65 AMG Style)
    Did you go for the wide body one???
     
  6. OP
    OP
    mmpaa

    mmpaa New Member

    Messages:
    10
    Joined:
    Jan 10, 2014
    Location:
    Cambridge
    Car:
    Mercedes E350
    Thanks for your help mate, I will try option 1 and see how I get on.
    I got the PD550, this doesn't include the front and rear fenders and bonnet.
    I will post pics once complete, hopefully tommorow.
     
  7. OP
    OP
    mmpaa

    mmpaa New Member

    Messages:
    10
    Joined:
    Jan 10, 2014
    Location:
    Cambridge
    Car:
    Mercedes E350
    Still couldn't get the DRL's working, i connected it directly to the original connection and at first i got few flashes and now nothing, that was using the original wiring loom with original ballast.

    I also tried using the loom that came with the DRL's, connected directly to the battery no luck then connected the positive to the cigarette lighter fuse on a different car as the fuse box in the Merc is located in the boot still no luck.

    Any way got the kit finished here are some pics.

    [​IMG]
    [​IMG]
    [​IMG]

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
     
  8. fazz

    fazz New Member

    Messages:
    1
    Joined:
    Nov 29, 2014
    Car:
    Mercedes E350
    Hi, you have any luck with the LED's?
     
  9. OP
    OP
    mmpaa

    mmpaa New Member

    Messages:
    10
    Joined:
    Jan 10, 2014
    Location:
    Cambridge
    Car:
    Mercedes E350
    Hello mate yes all done

    [​IMG]

    [​IMG]
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.