Help with Parktronic

Discussion in 'Electronics' started by o2drive, Sep 12, 2011.

  1. o2drive

    o2drive Hardcore MB Enthusiast

    Messages:
    113
    Joined:
    Apr 13, 2011
    Location:
    Clanfield
    Car:
    E320 CDI
    Hi all I've seen an answer somewhere on here to my problem but can't find it again.

    My problem is as follows, when it rains or has been raining (or after washing the car) when I move away all is fine. After applying the brakes all the water rushes off the bonnet and then I get 4 red leds and audible beep constantly from the Parktronic.This does stop eventually when the car has been driven for a while or dries out. :dk:
    Is there a way to stop the sensors getting wet to prevent this happening or have I got a more serious fault. Majority of the time everything is fine. :confused:
     
  2. developer

    developer MB Club Veteran

    Messages:
    8,165
    Joined:
    Dec 28, 2007
    Car:
    S212 E63 S
    I would suggest you have a faulty sensor, susceptible to water ingress.

    They are normally weatherproof (consider what they face when behind traffic in heavy rain for example).

    The quickest way to determine is to get the car hooked up to STAR (MB diagnostics) at an indie, or a main dealer (which will cost more).
     
  3. corned

    corned Hardcore MB Enthusiast

    Messages:
    3,894
    Joined:
    May 2, 2008
    Location:
    Living in error with Maude at Cap Ferrat
    Car:
    car
    MB parking sensors are notorious for not working in the presence of H2O.

    A quick search on here will reveal all.

    Pathetic really.
     
  4. SPX

    SPX MB Club Veteran

    Messages:
    15,600
    Joined:
    Aug 29, 2010
    Location:
    Ap Norf
    Car:
    That one
    Not that notorious, I've been on this forum 12 months and have never heard of parking sensors being dodgy.:confused:
     
  5. OP
    OP
    o2drive

    o2drive Hardcore MB Enthusiast

    Messages:
    113
    Joined:
    Apr 13, 2011
    Location:
    Clanfield
    Car:
    E320 CDI
    OK I'll pop down to PCS and see what's what
     
  6. OP
    OP
    o2drive

    o2drive Hardcore MB Enthusiast

    Messages:
    113
    Joined:
    Apr 13, 2011
    Location:
    Clanfield
    Car:
    E320 CDI
    Well went to see Ollie at PCS I may have a faulty sensor so I'll just see how it goes Thanks again to Ollie
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.