Help with Parktronic

o2drive

Active Member
Joined
Apr 13, 2011
Messages
113
Location
Clanfield
Car
E320 CDI
Hi all I've seen an answer somewhere on here to my problem but can't find it again.

My problem is as follows, when it rains or has been raining (or after washing the car) when I move away all is fine. After applying the brakes all the water rushes off the bonnet and then I get 4 red leds and audible beep constantly from the Parktronic.This does stop eventually when the car has been driven for a while or dries out. :dk:
Is there a way to stop the sensors getting wet to prevent this happening or have I got a more serious fault. Majority of the time everything is fine. :confused:
 

developer

MB Enthusiast
SUPPORTER
Joined
Dec 28, 2007
Messages
8,205
Car
Volvo V90 D5 AWD
I would suggest you have a faulty sensor, susceptible to water ingress.

They are normally weatherproof (consider what they face when behind traffic in heavy rain for example).

The quickest way to determine is to get the car hooked up to STAR (MB diagnostics) at an indie, or a main dealer (which will cost more).
 

SPX

MB Club Veteran
SUPPORTER
Joined
Aug 29, 2010
Messages
16,295
Location
Yorkshire
Car
That one
MB parking sensors are notorious for not working in the presence of H2O.

A quick search on here will reveal all.

Pathetic really.
Not that notorious, I've been on this forum 12 months and have never heard of parking sensors being dodgy.:confused:
 
OP
OP
O

o2drive

Active Member
Joined
Apr 13, 2011
Messages
113
Location
Clanfield
Car
E320 CDI
OK I'll pop down to PCS and see what's what
 
OP
OP
O

o2drive

Active Member
Joined
Apr 13, 2011
Messages
113
Location
Clanfield
Car
E320 CDI
Well went to see Ollie at PCS I may have a faulty sensor so I'll just see how it goes Thanks again to Ollie
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom