Horn not working - restarting ignition always resolves

Discussion in 'Electronics' started by Stocho, Sep 13, 2012.

  1. Stocho

    Stocho Hardcore MB Enthusiast

    Messages:
    296
    Joined:
    Jul 4, 2009
    Hi

    The car is E300TD 1998.

    Had this problem for a while. My horn quite often does not work. "Hummering" it etc does not work. But what always resolves it is switching ignition off then on. So the actual horns are OK, so is clockwork spring as it is hard to imagine how switching ignition off and then on again would fix it even temprarily. I did replace a relay in the fuse box. What else could it be? I have suspicion there is a circuit to switch off horn when car is being started - may be that circuit activates when it should not?

    The other problem I noticed is that sometimes the message indicating bulb failure appears but actual bulbs are OK.

    The other problem I had in the past but that resolved itself was with air heater in winter. It was just non responsive sometimes to tempreture changes on the controls. I had that for two years and then it fixed itself. No problem now but may be Horn is a related problem somehow.
     
  2. OP
    OP
    Stocho

    Stocho Hardcore MB Enthusiast

    Messages:
    296
    Joined:
    Jul 4, 2009
    Hi

    Based on no repplies I suppose my problem is very unusual. I have some additional information that might help others to help me...

    When driving the car pressing up and down on the key (not rotating it, by up and down I mean not in and out but with force applied perpendicular to the biggest surface of the key) makes kind of relay- like noise.

    If horn is not working it is sufficient to do that to make it work again. So looks like the problem is ignition key / socket related but strangely does not affect anything else apart from the horn!

    Any ideas on what and why could be causing it?
     
  3. trapperjohn

    trapperjohn MB Club Veteran

    Messages:
    7,316
    Joined:
    Nov 19, 2008
    Location:
    Lancashire
    Car:
    124 300D 24V Estate
    Perhaps the "cowl" around the key needs tightening a little. There must be something on the forum somewhere about how to change the EIS (Electronic Ignition Switch)

    Mind how you go though a new switch is around 600plus quid.
     
  4. dave e320

    dave e320 Active Member

    Messages:
    70
    Joined:
    Nov 22, 2008
    Location:
    kent
    Car:
    mercedes e 320 avantgard
    horn not working

    :thumb::thumb::thumb::thumb::thumb::thumb:
    it is the eis barrel? this has just been sorted on my e320 1999 by a1 merc of leyton at a cost of £540.00 it was starting to break down internaly causing the horn to stop working and the sunroof to not work at all. a big thank you to a1 merc for sorting this out when an auto electrician and merc dealers failed to act.
     
  5. vijilants

    vijilants Hardcore MB Enthusiast

    Messages:
    2,225
    Joined:
    Jan 23, 2007
    Location:
    London
    Car:
    C320CDI Sport W204
    The symptoms point towards the EIS is failing and as they charged you £500 + id say that they replaced the EIS.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.