i'm back! Sold my last CLS 350 a few years ago and now back with an E350 AMG coupe

Page may contain affiliate links. Please see terms for details.

MikeinCumbria

New Member
Joined
Aug 13, 2023
Messages
13
Location
Cumbria
Car
E350 coupe
Hi everyone,

Thanks for the add.

Been away for a few years but have another MB now so i'm back.

Picked up a very tidy E350 coupe at a reasonable price. However, couple of issues so i would be grateful if someone could tell me where best to post them?

Would like some help with:
  • the passenger windscreen wiper which only works sporadically
  • main beam comes on when i flash but not when i push the lever forward
Guessing the second point is electrical but not sure about the wiper issue.

I'm retired and don't want/have the money to put it into a dealership to have problems rectified so i would be grateful for any guidance.

TIA
 
Hi and welcome 👍.Sorry but I can't help with your issues.
 
Hi everyone,

Thanks for the add.

Been away for a few years but have another MB now so i'm back.

Picked up a very tidy E350 coupe at a reasonable price. However, couple of issues so i would be grateful if someone could tell me where best to post them?

Would like some help with:
  • the passenger windscreen wiper which only works sporadically
  • main beam comes on when i flash but not when i push the lever forward
Guessing the second point is electrical but not sure about the wiper issue.

I'm retired and don't want/have the money to put it into a dealership to have problems rectified so i would be grateful for any guidance.

TIA
Start by getting the fault codes read . Maybe consider an icarsoft scanner , which is a good bit of money saving kit for the diy’er
 
Maybe check for water in the front engine bay fuse/relay box and check the windscreen base drains are clear .
The fuse box is far left of the engine bay probably under a black cover (as you face the engine from the front of the car )
 
Hi everyone,

Thanks for the add.

Been away for a few years but have another MB now so i'm back.

Picked up a very tidy E350 coupe at a reasonable price. However, couple of issues so i would be grateful if someone could tell me where best to post them?

Would like some help with:
  • the passenger windscreen wiper which only works sporadically
  • main beam comes on when i flash but not when i push the lever forward
Guessing the second point is electrical but not sure about the wiper issue.

I'm retired and don't want/have the money to put it into a dealership to have problems rectified so i would be grateful for any guidance.

TIA
If You have the intelligent light system and the main light switch is at "A", then full beam will only come on when the road is clear and you are going above 30 mph. If you put the main light switch to the symbol that look like a dipped beam then high beam should work as normal when the stalk is pushed forward.
 
If You have the intelligent light system and the main light switch is at "A", then full beam will only come on when the road is clear and you are going above 30 mph. If you put the main light switch to the symbol that look like a dipped beam then high beam should work as normal when the stalk is pushed forward.
Thanks mate, i didn't know that, or about the ILS. That is crazy-good tech. Thanks for taking the time to reply. Much appreciated.
 
Maybe check for water in the front engine bay fuse/relay box and check the windscreen base drains are clear .
The fuse box is far left of the engine bay probably under a black cover (as you face the engine from the front of the car )
And thanks again for this, really good of you (and the others) to take the time to help me with this issue. Appreciate it mate. Will go and have a look now. Just got in from changing the lights setting (feel a right idiot for not knowing that) my last MB was a 2008 and didn't have the ILS.
 

Users who are viewing this thread

Back
Top Bottom