indicators only work sometimes

satumashirt611

Active Member
Joined
Nov 5, 2011
Messages
60
Location
ireland
Car
mercedes e220
doing the school run yesterday and all was fine until coming home when my indicators wouldnt operate at all or even the hazard lights.no clicking when you indicate either.made it home safely and they started working fine again.same thing today.any ideas.guessing its something loose but weather too bad to check yet.
 

Troon

MB Enthusiast
Joined
Aug 23, 2011
Messages
1,184
Location
Staffordshire
Car
A big one
Help us out a bit here: what car? Your profile says E220 - but what type (or year if you don't know).
 

@MARK

Active Member
Joined
Sep 2, 2011
Messages
756
Location
Spalding, Lincolnshire
Car
Audi A7 Quattro
I think they all do that.

I looked at the bulbs on mine and they come on, then go off, then come back on again and go off.

I think this is normal. :rolleyes:
 

Martyn_n

Active Member
Joined
Nov 27, 2010
Messages
612
Location
Leicester
Car
W124 E320, ML270
If it's a 124 there is a relay that deals with indicators, wipers and IIRC heated rear screen. I had a similar problem and cleaning the contacts in this, and all the fuses in the fuse box, made it go away.
 

GP801

MB Enthusiast
SUPPORTER
Joined
Jun 18, 2010
Messages
2,927
Location
Sussex and Tuscany
Car
2003 W209 CLK, 2005 R171 SLK in UK, 1995 S124 E280 in Italy
As above its likely to be the relay or fuse. The ceramic fuses deteriorate over time. They can look fine but give all sorts of odd problems. If you are unsure as to how old they are then its worth changing them all and cleaning the contacts at the same time.
 

SilverSaloon

MB Enthusiast
Joined
Mar 16, 2004
Messages
7,758
Car
1994 W124 E300D Estate, 1985 R107 280SL
the notorious N10 relay probably.

there are a few links on here that detail a fix - easy DIY if you get a small solder
 

brucemillar

MB Enthusiast
Joined
Nov 18, 2010
Messages
8,659
Location
Next Door to Alice - 25 'kin years now
Car
C55 AMG Wagon - W124 300te 4matic Wagon - BMW 4.8is X5 E53 - SWB Pajero 3.5 V6 24v
If you are replacing all the fuses (well worth doing IMO) be wary of the cheapies on ebay. I got a bag of these and most of them just blew. Ended up buying some (still cheap) from a motor factors. No issues at all with those. As said above clean all the contacts while you are at it. Take a pic on your mobile phone with the fuses in situ, if like me you are likely to forget the exact order of replacement.

FYI: The ebay ones were made of plastic and not ceramic. Not sure why this would cause them to blow but blow they did. The replacements were ceramic.
 
OP
OP
S

satumashirt611

Active Member
Joined
Nov 5, 2011
Messages
60
Location
ireland
Car
mercedes e220
i replaced all the fuses with proper ones and cleaned the contacts and nothing.the rear demister dosent work either.will have a look for the n10 relay fix
thanks everyone
 
OP
OP
S

satumashirt611

Active Member
Joined
Nov 5, 2011
Messages
60
Location
ireland
Car
mercedes e220
DELIGHTED,FOUND THE GUIDE ON SOLDERING THE RELAY AND IT WORKED PERFECTLY(so far,its been few minutes).IF IT STAYS IT WILL BE EXCELENT.WILL UPDATE LATER...THANKS EVERYONE..WHEN I TOOK OUT THE RELAY AND LOOKED AT IT IT LOOKED OK EVEN WITH A MAGNIFYING GLASS BUT I PUT BIT OF SOLDER ON ANYWAY AND PUT IT IN AND WORKED GREAT.VERY HAPPY WITH THIS QUICK FIX...
 
OP
OP
S

satumashirt611

Active Member
Joined
Nov 5, 2011
Messages
60
Location
ireland
Car
mercedes e220
spoke too soon,problem is back......will resolder it again tomorow to be sure.....is there anything else it might be...and how much for n10 relay
 

neilrr

MB Enthusiast
Joined
Jul 20, 2004
Messages
6,460
Car
Various.
James,

If you need a replacement N10 relay I have them.

Check your email.
 

Dec

MB Enthusiast
Joined
Jul 28, 2004
Messages
4,475
Car
C180,A.
ya thats the bit i soldered,im experienced soldering,did it for work for a few years ago.
Is your intermittent wiper, setting 1, failing at the same time as the indicators/hazards?

Dec
 

Hi-Ho Silver

Active Member
Joined
Jun 17, 2010
Messages
257
Location
Brighton
Car
C220 CDi SE Auto
Indicators are for lazy people. In my day we had to stop, get out of the car and wave in the general direction we intended to go; thus showing common courtesy to other road users. It's a disgrace that hand signals are no longer taught and for this I blame women and Italians.
 

Alex Crow

Active Member
Joined
Sep 30, 2011
Messages
277
Location
Super Suffolk
Car
S210 320cdi
Indicators are for lazy people. In my day we had to stop, get out of the car and wave in the general direction we intended to go; thus showing common courtesy to other road users. It's a disgrace that hand signals are no longer taught and for this I blame women and Italians.
Funny, but if Clarkson had said it we would be in for a national debate. :eek:
 

Dec

MB Enthusiast
Joined
Jul 28, 2004
Messages
4,475
Car
C180,A.
In my case, when the N10 failed, intermittently, I lost INTERMITENT wipers, speed 1 (not speeds 2 and 3) the indicators and hazards and rear screen demister, you seem to have 2 out of 3 faults so was wondering about the INTERMITENT wiper as you don’t mention it. I take it that you suspected the same joint failure as in my picture?

Dec

 
OP
OP
S

satumashirt611

Active Member
Joined
Nov 5, 2011
Messages
60
Location
ireland
Car
mercedes e220
ya was raining today and when the problem started the intermitent wipers didnt work either.
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom