Intermittant Sound Loss 02' C32

Beastlee

Active Member
Joined
Jul 31, 2011
Messages
64
Location
Preston, UK
Car
2014 S205 C250 CDi Sport Premium Plus
Hi,

I'm looking at a 2002 C32 Estate and the current owner has mentioned there's an intermittant loss of sound 'sometimes it works and then it won't'. Is there anything in particular I can look for to help resolve this? I know COMAND units are expensive and I wouldn't want to throw a lot of money at it to fix a sound issue.
The car has most of the extras, except for the sunroof, from what I've determined if that helps.

Thanks
Lee
 

Bobby Dazzler

MB Club Veteran
SUPPORTER
Joined
Jan 21, 2005
Messages
20,571
Location
Mittel England
Car
ML AMG-line Black Series
I can't think of any obvious known faults.

It might not be the COMAND unit itself - there are separate amps for the BOSE system.

Does it have any aftermarket connections, eg telephone, MP3, multimedia interface?
 
OP
OP
B

Beastlee

Active Member
Joined
Jul 31, 2011
Messages
64
Location
Preston, UK
Car
2014 S205 C250 CDi Sport Premium Plus
Sorry was referring to the entire audio/nav package rather than the COMAND control unit.

The only thing mentioned was the multi-changer. There's no apparent other add-ons but I'll ask as part of our communications today.
 
OP
OP
B

Beastlee

Active Member
Joined
Jul 31, 2011
Messages
64
Location
Preston, UK
Car
2014 S205 C250 CDi Sport Premium Plus
I've noticed there's a phone aerial on the back window, just in front of the high level brake light. I can only assume it has the merc phone kit but no cradle, can you confirm if this is stock or aftertermarket?
 

Bobby Dazzler

MB Club Veteran
SUPPORTER
Joined
Jan 21, 2005
Messages
20,571
Location
Mittel England
Car
ML AMG-line Black Series
Couldn't say for sure. If you have a photo you can post someone may be able to advise.
 
OP
OP
B

Beastlee

Active Member
Joined
Jul 31, 2011
Messages
64
Location
Preston, UK
Car
2014 S205 C250 CDi Sport Premium Plus
I've attached aerial and COMAND shots to see if it offers any clues.
 

Attachments

  • IMGP1667.jpg
    IMGP1667.jpg
    70 KB · Views: 17
  • IMGP1678.jpg
    IMGP1678.jpg
    223.4 KB · Views: 17

marty359

Active Member
Joined
May 24, 2005
Messages
904
Location
The Fens
Car
BMW 330d with indicators and Jeep Renegade also with indicators
I think ive seen this C32 advertised and it has Bose.

I had a problem with my system cutting out over a period of time and then stopping all together, it turned out to be the Bose amp. The display would say no CD when the CD button was pressed.

This helped me out http://www.carstereohelp.com/mercedesFiberOptic.htm

Cd changers are about £100 amps are rare and I managed to get one off a C32 breaking on ebay. Euromercs have one listed for sale.....or they did last month.
 

Users who are viewing this thread

Top Bottom