Intermittant Sound Loss 02' C32

Discussion in 'Electronics' started by Beastlee, Aug 15, 2011.

  1. Beastlee

    Beastlee Active Member

    Messages:
    64
    Joined:
    Jul 31, 2011
    Location:
    Preston, UK
    Car:
    2014 S205 C250 CDi Sport Premium Plus
    Hi,

    I'm looking at a 2002 C32 Estate and the current owner has mentioned there's an intermittant loss of sound 'sometimes it works and then it won't'. Is there anything in particular I can look for to help resolve this? I know COMAND units are expensive and I wouldn't want to throw a lot of money at it to fix a sound issue.
    The car has most of the extras, except for the sunroof, from what I've determined if that helps.

    Thanks
    Lee
     
  2. Bobby Dazzler

    Bobby Dazzler MB Club Veteran

    Messages:
    15,389
    Joined:
    Jan 21, 2005
    Location:
    Mittel England
    Car:
    ML AMG-line Black Series
    I can't think of any obvious known faults.

    It might not be the COMAND unit itself - there are separate amps for the BOSE system.

    Does it have any aftermarket connections, eg telephone, MP3, multimedia interface?
     
  3. OP
    OP
    Beastlee

    Beastlee Active Member

    Messages:
    64
    Joined:
    Jul 31, 2011
    Location:
    Preston, UK
    Car:
    2014 S205 C250 CDi Sport Premium Plus
    Sorry was referring to the entire audio/nav package rather than the COMAND control unit.

    The only thing mentioned was the multi-changer. There's no apparent other add-ons but I'll ask as part of our communications today.
     
  4. OP
    OP
    Beastlee

    Beastlee Active Member

    Messages:
    64
    Joined:
    Jul 31, 2011
    Location:
    Preston, UK
    Car:
    2014 S205 C250 CDi Sport Premium Plus
    I've noticed there's a phone aerial on the back window, just in front of the high level brake light. I can only assume it has the merc phone kit but no cradle, can you confirm if this is stock or aftertermarket?
     
  5. Bobby Dazzler

    Bobby Dazzler MB Club Veteran

    Messages:
    15,389
    Joined:
    Jan 21, 2005
    Location:
    Mittel England
    Car:
    ML AMG-line Black Series
    Couldn't say for sure. If you have a photo you can post someone may be able to advise.
     
  6. OP
    OP
    Beastlee

    Beastlee Active Member

    Messages:
    64
    Joined:
    Jul 31, 2011
    Location:
    Preston, UK
    Car:
    2014 S205 C250 CDi Sport Premium Plus
    I've attached aerial and COMAND shots to see if it offers any clues.
     

    Attached Files:

  7. marty359

    marty359 Hardcore MB Enthusiast

    Messages:
    898
    Joined:
    May 24, 2005
    Location:
    The Fens
    Car:
    BMW 330d with indicators and Jeep Renegade also with indicators
    I think ive seen this C32 advertised and it has Bose.

    I had a problem with my system cutting out over a period of time and then stopping all together, it turned out to be the Bose amp. The display would say no CD when the CD button was pressed.

    This helped me out http://www.carstereohelp.com/mercedesFiberOptic.htm

    Cd changers are about £100 amps are rare and I managed to get one off a C32 breaking on ebay. Euromercs have one listed for sale.....or they did last month.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.