Intermittent fault on Unlock of car

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
Reaching out for help on here as I have a real headache from my 2012 C350 CDI,


Basically the problem occurs mostly when the car is left parked overnight and I go to it the following morning, when I unlock the car the interior lights do not come on, I know then that I am going to have problems. When I then get in the car and put the key in the ignition, none of the electrical systems start. So no command, no brake lights, no speedo (just the computer screen in the middle of the speedo and every warning light on)


turn the key to the 2nd notch i.e. (not starting the engine) and it starts displaying errors:-


starts with cruise control and speedtronic inoperative,

then parking guidance inoperative,

then ABS and traction control is inoperative,

then front left airbag malfunction, then front right airbag,

then restraint system malfunction,

PER-SAFE malfunction,

run flat indicators inoperative and then it cycles back through these errors.


If I start the car, it starts no problem at all, I’ve checked and the car side lights and headlights work, but the brake lights do not, so I think that is why it locks the car in park. If I remove the cover from the gear leaver, and override the park lock, I can drive the car mechanically with no problems at all, just that none of the electrical systems are on, so no powered steering no indicators, no aircon or speedo. So not safe to drive, but I drove it to the garage like that last year and it functioned through the engine and gearbox no problem.


What is really frustrating is it clears the errors and leave no trace of the problem on diagnostics. So on Sunday, it happened, I drove 3 miles to costa, locked the car had a coffee and when I came out 15 minutes later it unlocked and the car was fine, no errors or signs of any error. Also on a morning many times if I turn the key from off to the 2nd turn 3 to 5 times on the go the errors all clear and its fine. But some days I have tried for 2 hours to get it to clear and it doesn’t.


I had it at the garage they could see signs of water ingress in the front fuse box with corrosion in there, I had it replaced which was nearly £1000, it was fine for 10 days then just started again. I also have measured the car battery, when it is fine and when it isn’t and voltage wise there are no issues, tends to be 13v ish, charges at 14.5/6 when the engines on and when it errors or doesn’t error it have 12v plus in the battery (that’s the rear one in the boot, the front one I think is the stop start one and is usually 13v plus).


This happens about every 3 to 5 days and then is fine for a few days, if I unlock the car and the lights come on I know all day it will be fine, also I have never had it error when I’m driving it only when I unlock/start the car.


So help please as it is so annoying
 

ash59fifty-uk

MB Enthusiast
Joined
Aug 9, 2015
Messages
3,819
Location
The shire
Car
C204 C63, VW Transporter
Do you ever have symptoms of the steering lock not letting go? Including swallowing the key briefly, I.e nothing moves and you can’t move the key out of the ignition
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
Do you ever have symptoms of the steering lock not letting go? Including swallowing the key briefly, I.e nothing moves and you can’t move the key out of the ignition
No I’ve never had any issues with the steering lock or key removal
 

artyman

MB Enthusiast
SUPPORTER
Joined
Mar 4, 2011
Messages
2,488
Location
Hampshire
Car
C 200 CDI Sport
Sounds like a duff battery, I had similar messages when my battery was running low, alternator wasn't charging it, but I knew it was the alternator.
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
Sounds like a duff battery, I had similar messages when my battery was running low, alternator wasn't charging it, but I knew it was the alternator.
That’s what I thought it was but I’ve checked the vaultage and alternator charge and it seems to be normal, could be amps are affected I suppose but vaultage seems ok. It’s the original merc battery so it’s 6 years old and could be due a replacement
 

artyman

MB Enthusiast
SUPPORTER
Joined
Mar 4, 2011
Messages
2,488
Location
Hampshire
Car
C 200 CDI Sport
As far as I remember it started shutting down stuff progressively with some of your messages, my car doesn't have some of your options
 

toolman1954

MB Enthusiast
SUPPORTER
Joined
Sep 16, 2004
Messages
1,110
Location
Leven, Fife / Northampton
Car
2003 320 CDI Avantgarde, 1997 312d Sprinter
As per post 4.... I would get both your Batteries changed if they are now 6 years old. Modern cars are very power hungry and once the batteries start waning, strange things start happening. Batteries a a hefty investment but you might get another 6 years out of them. Try your dealer for a battery quote, or even other Mercedes dealers that advertise on Ebay.

Steve.
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
Still no luck with this it just getting worse if anything, had both battery’s checked and they are fine and don’t need replacing, it was cold here yesterday and car would not shift left it running to warm the engine bay up as interior electrics don’t work the car AC is off so no way to warm the interior up. Left it for 30 min, still no wouldn’t work. Left it for another 20 minutes switched off then it unlocked and everything came on straight away. So annoying that I’m no closer to fixing it, all the lights go funny now, drivers side indicators don’t flash when it is erroring, when you start it the front passenger side lights come on the drivers side don’t. It’s going to have to go back into the garage but diagonistics shows nothing, so it’s pretty difficult to fix with no errors
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
Just found similar problem online and they replace the auxiliary battery relay, which is the F32 pre fuse box relay, something to do with a g30 error where the relay hasn’t closed which results in no vaultage to the rear Sam and no wake up from it until the relay closes. Which all make sense if that is what it is, going to talk to the garage tomorrow as I can understand a faulty relay causing an intermittent fault, but I’ll see what they say
 

clk320x

Hardcore MB Enthusiast
SUPPORTER
Joined
Sep 27, 2016
Messages
11,014
Location
East Midlands
Car
W212 E250 CDI Sport & S211 E320 CDI Avantgarde - SOLD: S203 C32 AMG, W209 CLK320
How were the batteries tested?
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
By a local battery specialist, cranking amps, voltage and charge all spot on. He said they were mint batteries and as he only sells car batteries I would doubt that he would not know what he was doing with them. I also had my tracking adjusted yesterday and I asked them to do battery checks at national tyres again they could find no issues with the battery. I’ve also charged the battery and it still errors with a full battery and I’ve also connected jump leads to the car when it is erroring and it still persists when connected to my wife’s car with her engine running so I can’t see how or why it is the battery. I’ll see what the garage says today as it is something very simple as once the wake up signal is received everything is fine, just that every few days when I unlock it the car wake up signal is not being triggered so a relay makes sense.
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
I have never had the garage be able to get any errors as the car doesn’t error when they have had it. I did drive it to them once with all the errors on it it and the millisecond they plugged in the diagnostics that triggered the wake up and everything turned on. So it is proving very difficult to diagnose the lack of it waking up when the first thing diagnostics does is wake it up, and it doesn’t record very much linked to it
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
Looks like it has completely failed now, errored yesterday in the icy weather. Got it to the garage and diagnostics, it is just full of can errors, I picked up a courtesy car last night and it was still erroring then which it has never done before which can only be a good thing. Just wait to see now what it turns out to be, I found this online about F32 design fault in 2012 models but took some finding, maybe this isn’t the problem but it is exactly the issues I’ve been suffering from intermittently for the last 18 months.

Problem job: Mercedes 212 f32 fuse box design fault
 
OP
OP
J

Jonahx

New Member
Joined
Oct 2, 2018
Messages
12
Location
lancashire
Car
C350 CDI
Got it back today with it having been in the garage for a week, finally failed completely last Monday, had it all checked out and it was the F32 fuse box. None available in the UK so must be in demand, Mercedes parts had one shipped in from Germany, garage got the part today, fitted it and it is now fine. So if you have intermittent fault and you are searching forums for stupid errors that make no sense and then 5 minutes later they go away, don’t buy a new battery get your F32 fuse box looked at. It is basically closing off the network to all computers in the car as a hard shut down which if you work in IT computers hate, hence them malfunctioning when they are turned back on, as they didn’t shut down themselves correctly due to the malfunctioning F32 fuse box. Mine was £166 plus vat (£200)
 

Gbrowncls55

MB Enthusiast
Joined
Sep 11, 2016
Messages
1,145
Location
Surrey
Car
CLS55 AMG 06, SL350 06, 996 cab, all current. Gone : E500 W211, 2x M5s and far,far too many 911s
My 350 sl does intermittent electrical silliness similar to yours.....been to specialist loads of times but pretty impossible to find cause as it usually doesn't do it when they have it. Might get that relay replaced just in case. small price to pay if it works.
 

Users who are viewing this thread

Top Bottom