Intermittent sidelight fail

jonthetourist

Active Member
Joined
Feb 2, 2011
Messages
174
Location
Glos
Car
SL 300-24
Hi

My rear o/s sidelight fails from time to time. It's not the bulb, as swapping with the n/s one shows the bulb is working. Fiddling with the seating appears to make no difference, then it starts working again. And so the cycle goes on.

Anyone any thought? Fuses are all good.

Cheers

Jon
 

SKIPPERDOG

Member
Joined
Feb 14, 2011
Messages
57
Location
dublin
Car
211 320cdi
What model is it ? Is the bulb holder ok ? Has the. Connection between the bulb holder and lamp melted ?
 
OP
OP
J

jonthetourist

Active Member
Joined
Feb 2, 2011
Messages
174
Location
Glos
Car
SL 300-24
What model is it ? Is the bulb holder ok ? Has the. Connection between the bulb holder and lamp melted ?
It's a 1991 R129, so old enough to be tired. Everything looks absolutely fine. I have tried to tweak upwards the two springy connectors at the base but they seem to have life in them.

It's a puzzle.
 
OP
OP
J

jonthetourist

Active Member
Joined
Feb 2, 2011
Messages
174
Location
Glos
Car
SL 300-24
It's a 1991 R129, so old enough to be tired. Everything looks absolutely fine. I have tried to tweak upwards the two springy connectors at the base but they seem to have life in them.

It's a puzzle.
Just following up my own post - I detached the two rear light holders and swapped them. The fault moved over so I guess the next step is to dismantle the unit and check all the wires. Too sunny to do it this afternoon though.

Jon
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom