Key Fob not turning in ignition

Spera

Active Member
Joined
Aug 9, 2010
Messages
243
Location
WIGAN
Car
2002 E CLASS 270CDI AUTO AVANTGARDE
Hello to all this evening. As the title states it wont turn in the ignition.Before posting I have scoured the forum for similar issues.These are the train of events:
I only have one fob and therefore do not have the option presently to test another fob.
All doors / boot open and lock with the fob so batteries are fine=I know from forum this works independantly(eg you can take batteries out and still start the car with fob).
Insert the fob into ignition and there is no sound/buzz(this buzz lets you know the stearing unlocks and allows you to turn key).
If I press any of the three buttons on my fob whilst it is inserted the buzz sound will work 8/10 times and I can turn to position 1.
when I turn to position 2 all consumers work fine untill I turn to position 3 (start car) then fuel gauge/coolant gauge/speedometer / basically all the instrument clusters dont work. The lights work well headlights etc but no indicators.
When I turn car off the key wont turn again maybe turns 1/20 tries unless I follow the above procedure.
Tried Star which recognises a fob has been inserted into the grooves of the ignition but does not read from the fob eg will not release the stearing lock.
To go any further I need a fob anyway as no good to have just one so I will order one fob tomorrow for next day delivery and pick the manual silver part up later as it takes 5 days.Hopefully I can find someone to repair my current fob and replace fob cover as Ive read from forum that the transponder coil can break.My current fob is in a sorry state its cracked on two points and has a slight hole on the unlock pad.
I checked all fuses and some relaysto see if there was a broken fuse but all good .Problem now is when I follow above procedure It comes up with a malfunction no ESP see owners manual. Ive probably caused this.
I couldnt see anything on any forum regards why the Fob will turn following above procedure.
Action is get new fob if solves issue great if not put on star with new fob.
Thanks again for all the help on previous faults and apologies for War & Peace.
 

GP801

MB Enthusiast
SUPPORTER
Joined
Jun 18, 2010
Messages
3,003
Location
Sussex and Tuscany
Car
2003 W209 CLK, 2005 R171 SLK in UK, 1995 S124 E280 in Italy
Hopefully just the fob but it could be the electronic ignition switch. You probably wont know until you try the new fob. We had something similar when our old 203 was still under warranty. Neither key worked but the dealer insisted they get new keys because thats what MB told them to do. No surprises then when it was no different. It was the switch itself.
 
OP
OP
Spera

Spera

Active Member
Joined
Aug 9, 2010
Messages
243
Location
WIGAN
Car
2002 E CLASS 270CDI AUTO AVANTGARDE
Hopefully just the fob but it could be the electronic ignition switch. You probably wont know until you try the new fob. We had something similar when our old 203 was still under warranty. Neither key worked but the dealer insisted they get new keys because thats what MB told them to do. No surprises then when it was no different. It was the switch itself.

Hopefully it is the Fob at £220 as the electronic ignition switch is another £400 ish i think
 
OP
OP
Spera

Spera

Active Member
Joined
Aug 9, 2010
Messages
243
Location
WIGAN
Car
2002 E CLASS 270CDI AUTO AVANTGARDE
Got the new fob today and it works , no esp / any malfunctions , all consumers working as should . So it was a new fob in my case £227 inc vat.
 

GP801

MB Enthusiast
SUPPORTER
Joined
Jun 18, 2010
Messages
3,003
Location
Sussex and Tuscany
Car
2003 W209 CLK, 2005 R171 SLK in UK, 1995 S124 E280 in Italy
Good result.
 

LeeB

New Member
Joined
Jun 22, 2013
Messages
14
Car
W213 220d AMG Line
Problems with dead key on my S203

Hello all, I'm a "newbie" so apologise in advance to those of you rolling your eyes upwards and thinking I should know this or have found it elsewhere.

I have problems with one of my keys not working in my 2002 S203 C220 CDI - one of them does everything I want and the other one will now only operate the central locking. I have plenty of batteries and have swapped batteries round with the "good" key, so they are not the problem.

The problem key will not turn in the ignition switch and no buzzing sound is made from the switch. This was a working key until I put it aside in December last year, thinking I had no problems in the event of losing my other key.

The only reason I found out that my spare key wasn't working was when I tried to start the car with it the other day. There is nothing in my handbook to tell me how to get the key working again and I am puzzled as to why it's decided to take its bat in when it was working fine in December.

All help is appreciated.:confused:
 

bobt43

New Member
Joined
Sep 28, 2013
Messages
2
Location
Ayr
Car
E220 CDI
Transponder Key Repairs

Hello, I run a small electronic repair business from home in Ayr and recently was asked to look at a faulty key for a friends Vito van that was not recognised when inserted in the lock. I managed to repair it and decided to contact a local independent garage to give my contact details if any of their customers had a similar problem, a few weeks later got another one for an A class and managed to repair that also. I hope that it is permissible for me to discuss this in this forum as I am new to it.
 

LittleG

Active Member
Joined
Mar 31, 2010
Messages
98
Location
Essex/Fife
Car
05 C220 Avantgarde Wagon
my fob has issues, but i live with them.

  • It opens and locks the car up no dramas
  • batteries don't last very long used to be a month or so but i switched brand and these are lasting a while
  • when I insert it into ignition noting happens until I press the unlock button again and all is well.
  • opening and closing the windows is a bit hit and miss.
  • if I stall the car I have to completely remove the key and restart or it will die right after starting or it will start with no electrics, radio, dash instruments etc.
The spare key doesn't unlock the car but works in the ignition no problem.
 

hobbecat

New Member
Joined
Aug 31, 2014
Messages
2
Car
c220cdi
Hello to all this evening. As the title states it wont turn in the ignition.Before posting I have scoured the forum for similar issues.These are the train of events:
I only have one fob and therefore do not have the option presently to test another fob.
All doors / boot open and lock with the fob so batteries are fine=I know from forum this works independantly(eg you can take batteries out and still start the car with fob).
Insert the fob into ignition and there is no sound/buzz(this buzz lets you know the stearing unlocks and allows you to turn key).
If I press any of the three buttons on my fob whilst it is inserted the buzz sound will work 8/10 times and I can turn to position 1.
when I turn to position 2 all consumers work fine untill I turn to position 3 (start car) then fuel gauge/coolant gauge/speedometer / basically all the instrument clusters dont work. The lights work well headlights etc but no indicators.
When I turn car off the key wont turn again maybe turns 1/20 tries unless I follow the above procedure.
Tried Star which recognises a fob has been inserted into the grooves of the ignition but does not read from the fob eg will not release the stearing lock.
To go any further I need a fob anyway as no good to have just one so I will order one fob tomorrow for next day delivery and pick the manual silver part up later as it takes 5 days.Hopefully I can find someone to repair my current fob and replace fob cover as Ive read from forum that the transponder coil can break.My current fob is in a sorry state its cracked on two points and has a slight hole on the unlock pad.
I checked all fuses and some relaysto see if there was a broken fuse but all good .Problem now is when I follow above procedure It comes up with a malfunction no ESP see owners manual. Ive probably caused this.
I couldnt see anything on any forum regards why the Fob will turn following above procedure.
Action is get new fob if solves issue great if not put on star with new fob.
Thanks again for all the help on previous faults and apologies for War & Peace.
Hi
Have you managed to overcome this, i have the same problem, Mercedes put new batteries in the key and i can start the car with limited electrics, but no indicatitors ?
 

hobbecat

New Member
Joined
Aug 31, 2014
Messages
2
Car
c220cdi
Got the new fob today and it works , no esp / any malfunctions , all consumers working as should . So it was a new fob in my case £227 inc vat.
what info do you need to provide for a new fob please ?
VIN and reg , is that all ?
 

Users who are viewing this thread

Top Bottom