LCD Dash on 220CDI Year 2000

Discussion in 'Electronics' started by AndyB1, Jul 19, 2007.

  1. AndyB1

    AndyB1 New Member

    Messages:
    5
    Joined:
    May 1, 2006
    Hi, Can anyone advise me regarding the Crystal display on the dash, ie, Miles, Tripometer, Clock etc. The crystals are either not illuminating or hardly illuminating. Presently I cannot read any of the digits. This has progressively got worse over the last six months.
    Thanks. Andy
     
  2. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
  3. PeterE320Cdi

    PeterE320Cdi Hardcore MB Enthusiast

    Messages:
    472
    Joined:
    Apr 2, 2006
    Location:
    Devon
    Car:
    S210 E300 DT, XC60 Past Cars: S210 E320 CDi (rusted into the ground), CLK 240
    The instructions on how to fix the problem are on post 18 of the thread which Dieselman posted.

    I did mine 10 months ago and it is still working fine.:)
     
  4. OP
    OP
    AndyB1

    AndyB1 New Member

    Messages:
    5
    Joined:
    May 1, 2006
    Thanks for this info guys. Two of the three displays are back fully. The third is 'taking its time'. I'll give it a week and then check my fixings again.
    Thanks again.:bannana:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.