Limp mode C250 bluetec.

Animal

Member
Joined
Oct 8, 2014
Messages
32
Car
C250d Bluetec Sport Premium Plus, Est
I have an intermittent limp mode issue on a 2014 s205 62k.
My icarsoft MB V2.0 shows no fault codes and there is no eml.
I use it mainly for short journeys so took it out for a thrashing to try to clear it out, but no joy. Gear change has been a bit jerky as well(7spd auto).
Any ideas gratefully received.
 

Scottieman

New Member
Joined
Aug 31, 2021
Messages
9
Location
Edinburgh
Car
Mercedes 2.8cdi W211
I was on holiday making my way with my E-Class Mercedes towing a caravan to Portsmouth to catch the Ferry to Santander when I suddenly found the Auto Gearbox

would not change up leaving the car in what’s termed as Limp Mode i.e. basically stuck in 2nd gear.

I called Martin the owner of ControlUnits who kindly offered to see what could be done at such short notice to help.

He made arrangements for his team to carry out an urgent repair.

This meant getting the car to him at his workshop at Uffculme Cullompton.

My wife and I sat in Reception for 4 hours whilst the repair was done, a faulty Speed Sensor on the Automatic Gearbox 722.9 TCU Conductor Plate Board.

During the 4 hour wait we were able to witness first hand how Sam on reception fielded all the calls in a very professional manner.

Martin the owner took the time to explain, after closer inspection after removal, why my Auto Gearbox TCU control plate had failed.

I was left, after my visit and successful repair in record time, very impressed by the professionalism of the team and the cleanliness of the workshop. The staff all seemed to be happy in their work. I suspect the easy calm manner of Martin the owner has a lot to do with that.

Needless to say I am very grateful to Martin and his team at ControlUnits who went above and beyond to help out a weary stranded traveller.
 

Users who are viewing this thread

Top Bottom