Losing drive

Discussion in 'Engine' started by Danny DeVito, Jun 26, 2011.

  1. Danny DeVito

    Danny DeVito Hardcore MB Enthusiast

    Messages:
    886
    Joined:
    Nov 1, 2009
    Location:
    Ireland
    Car:
    V220 CDI
    Recently topped up my autobox because i thought it was low and it was it needed 2 litres of atf. The box 4hp20. The problem i had is still there and is getting worse. On the motorway when i go over 60 it feels like someone is pulling the car back, like when you tow someone and they keep jerking on the rope. Also on other roads it happens more when the car bounces up and down and when i move the steering. The engine revs don't change. Now its happening at 50 mph. If i accelerate hard from stop it goes smoothly up until it hits 50-60. When it happens on the motorway it feels like the car is pulling to one side as if perhaps losing drive on one side, or this could be just steering play from power on/off. I can't bring it to MB at the moment so any suggestions gratefully received
     
  2. jaymanek

    jaymanek Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    16,400
    Joined:
    Nov 29, 2002
    Location:
    Nuneaton Warwickshire
    Car:
    Lots of Mercedes!
    sounds like a torque convertor issue maybe.
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.