Maf

Discussion in 'Engine' started by Mark Ager, Apr 9, 2014.

  1. Mark Ager

    Mark Ager Active Member

    Messages:
    60
    Joined:
    Jun 7, 2012
    Car:
    mercedes c 270
    I changed my Maf a ittle while ago for one i bought from EURO car parts and it seemed ok i then attampted to do a EGR delete wasnt 100% sure i had the wiring right, limp mode started appearing again under acceleration. Decided to remove the EGR Mod, am still having limp home mode problems is it possible ive damaged the Maf Aagain? Are the euro car parts Mafs ok? Should i get a merc 1 ? Or get a second hand 1 off the net?
     
  2. LexCorp

    LexCorp New Member

    Messages:
    16
    Joined:
    Mar 3, 2014
    Car:
    W203 c220 CDI
    I got a bosch maf from eurocarparts which had the exact code and looked identical to the original which was also bosch. You should be able to check if it is working with a obd scan tool that can display air flow rate or use a volt meter on the maf sensor and see if you get signal when you rev the engine.
     
  3. BlackC55

    BlackC55 Authorised Forum Sponsor Authorised Forum Sponsor

    Messages:
    18,313
    Joined:
    Feb 8, 2007
    Location:
    Horndean, Portsmouth, Hampshire, Southsea
    Car:
    C43 AMG with a 55 engine and supercharger, MK1 Caddy, S500, etc
    You will have a Peirburg MAF on the 270. They are fine and OE spec.

    You need to read the codes and check the live data.
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.