MAS? Where abouts?!?

Discussion in 'Engine' started by Will, Nov 23, 2003.

  1. Will

    Will Hardcore MB Enthusiast

    Messages:
    11,357
    Joined:
    Jan 21, 2003
    Location:
    Surrey
    Car:
    GL63 AMG / 190E 2.5-16 / Porsche 911
    I have a problem with my 1996/P C200 Esprit (Manual).
    Over the last few months I have noticed on rare occasions a sort of hesitation with regards to power delivery.
    Eg, if you were in say 4th doing 40ish and put your foot straight down, it would slowly pick up as you'd expect. However, on a few occasions it would cut out. Ie, it would hiccup and stop picking up as it should. As you release your foot from the full (or there abouts) throttle position it would return to as it was just before the problem.
    I was going to have this addressed on the next service as it was only an intermittent fault and didn't have any other problems.
    Anyway, was away for a couple of weeks and left the car in the garage. I had been giving it a clean and realised that in listening to the stereo the battery was low/flat.
    Charged battery and thought nothing of it.
    A week later, started the car and it seemed ok, except that now it has got a similar fault to what I had before, but permanent.
    It will not rev past 4000 rpm.
    Tried restarting etc etc, checked everything silly/obvious under the bonnet.
    Was thinking of checking out where the MAS was and I can't find one. Working through from the air filter up to where the inlet is and the only type of sensor I can find is a little tiny push fit thing - nothing like the jubilee clip and spring clip-mounted one that Graham C230K has.
    I take it I must have either a MAS or air-flow sensor of some kind?
    Any other possiblilities for my symptoms?
    Thanks for any help in advance.
    Will
     
  2. pluggers

    pluggers MB Enthusiast

    Messages:
    2,022
    Joined:
    Feb 13, 2003
    Location:
    Staffordshire
    Car:
    CLK 200 kompressor w209
    I cant be of much help on this one but from what you describe you haven't got a MAS to worry about.If yours is a pre face lift model like mine it wont have one(check my sig piccy).Only the face lift models have them.It maybe just down to a simple thing like the spark plugs that need changing,Do you know when they were last done?
     
  3. OP
    OP
    Will

    Will Hardcore MB Enthusiast

    Messages:
    11,357
    Joined:
    Jan 21, 2003
    Location:
    Surrey
    Car:
    GL63 AMG / 190E 2.5-16 / Porsche 911
    The plugs were last changed about a year ago (less than 10,000 miles since!)
    I suppose mine is sort of in-between facelifts. It is not the major post '97 spec, but has the clear lenses, light smoke rear lamps, remote locking with Red/Green LED's etc.
    I am not sure whether the fault is related to the two weeks of storage or the charging of the battery or whether it is all a coincidence!
    If my car does not have a MAS sensor, It must use an air flow meter or similar?!?
    The only items I have noticed are a tiny sensor or valve etc located next to ABS pump which is connected to a very small air tube?!? And, there is a black rectangular BOSCH box on the back of the throttle butterfly/flap unit?
    Can anyone explain what these units are?
    Also, am I right in thinking that the little sensor that does push fit into the air inlet tubing between the air filter and the inlet is a temperature sensor or something?
    Many thanks in advance,
    Will
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.