Mercedes citan lights permanently on and indicator stays on going right..

Page may contain affiliate links. Please see terms for details.

Harryegg79

New Member
Joined
Feb 1, 2023
Messages
9
Location
Liverpool
Car
Mercedes citan
Can anybody help I’ve bought citan and the lights won’t turn off the indicators stays on right side only I have no window wipers, the light switch does nothing but if I pull the fog lights on I can use both indicators like normal, the front drivers and passenger foot wells had poodle in but I’ve now dried and on passenger there is wiring loom and plug which I dried out, am wondering if this could have blew any modules? any help would be much appreciated
 
Can anybody help I’ve bought citan and the lights won’t turn off the indicators stays on right side only I have no window wipers, the light switch does nothing but if I pull the fog lights on I can use both indicators like normal, the front drivers and passenger foot wells had poodle in but I’ve now dried and on passenger there is wiring loom and plug which I dried out, am wondering if this could have blew any modules? any help would be much appreciated
And diagnostic won’t read anything?
 
Front SAM has got possibly got wet, wet electrics in these modern networked vehicles is problematic .. you need to find someone with proper Xentry diagnosis and lots of electrical knowledge (I don't know of anyone in Liverpool I'm afraid)

R
 
Front SAM has got possibly got wet, wet electrics in these modern networked vehicles is problematic .. you need to find someone with proper Xentry diagnosis and lots of electrical knowledge (I don't know of anyone in Liverpool I'm afraid)

R
Booked in wed for the proper diagnostic, I’ve located the both of them 1 is behind glove box the other behind steering column , thanks for reply richard
 

Attachments

  • BFA2D5BC-31C3-43F2-BF33-659AC69140F3.jpeg
    BFA2D5BC-31C3-43F2-BF33-659AC69140F3.jpeg
    1.4 MB · Views: 8
  • 61CE31E7-8FB4-45F4-AA60-27BDA8518D43.jpeg
    61CE31E7-8FB4-45F4-AA60-27BDA8518D43.jpeg
    874.6 KB · Views: 8
What was the outcome of your problem please ? I’ve currently got a similar issue . Snap on tool says n80 steering module , which I guessing is black rectangle box in one of your pictures ? As the other one is the BCM
 
What was the outcome of your problem please ? I’ve currently got a similar issue . Snap on tool says n80 steering module , which I guessing is black rectangle box in one of your pictures ? As the other one is the BCM
What was the outcome of your problem please ? I’ve currently got a similar issue . Snap on tool says n80 steering module , which I guessing is black rectangle box in one of your pictures ? As the other one is the BCM
That’s the one it’s just above steering column it’s clips out that’s what sorted my problem now all lights indicators work you will probably get it on eBay take yours out first to match correct model no.
 
Just take plastics all out from under steering column and you will see it just behind column get your light under there I think it pushes up
Thank for the reply ! Yes currently :
My indicators , window wipers , headlight selector switch and the push button for
Mpg and stuff doesn’t work ,

Headlights are permanently on and when I plugged it into a snap on reader it said line 1- line 5 in n80 steering column switch is short circuit or open circuit . I’ll have a look tomorow ,
 
Thank for the reply ! Yes currently :
My indicators , window wipers , headlight selector switch and the push button for
Mpg and stuff doesn’t work ,

Headlights are permanently on and when I plugged it into a snap on reader it said line 1- line 5 in n80 steering column switch is short circuit or open circuit . I’ll have a look tomorow ,
Yes that’s what solved my problem, make sure there is no water in passenger and drivers footwells, mine was saturated, someone jet washed back of van and water went behind both seats which blew that module, if you get stuck message me
 
Yes that’s what solved my problem, make sure there is no water in passenger and drivers footwells, mine was saturated, someone jet washed back of van and water went behind both seats which blew that module, if you get stuck message me
I couldn’t see any water in footwells , well not underneath the floor mats ? Is that where you mean ? I have already had the bcm module off and everything was bone dry . Going to look at that steering module tomorrow. Strange how water on the floor blew the module , as the modules up near steering wheel.

Thanks again for reply’s
 
I couldn’t see any water in footwells , well not underneath the floor mats ? Is that where you mean ? I have already had the bcm module off and everything was bone dry . Going to look at that steering module tomorrow. Strange how water on the floor blew the module , as the modules up near steering wheel.

Thanks again for reply’s
No lift rubber mat and feel all around footwell, my module was dry but there is wires in footwell what got wet and blew the module, you need to make sure the reason why it blew is fixed. 👍🏼
 

Users who are viewing this thread

Back
Top Bottom