Mercedes Connect Me

Page may contain affiliate links. Please see terms for details.
Yep dealer sets you up on the system and you just follow a few simple instructions when the email from Daimler is sent to you. Agree seems to be a bit hit and miss, but preheat worked a treat for me this morning! :thumb:
 
I went into my local dealer yesterday to get Connect Me activated on my C350e and because the technician was busy they took my details and said they'd give me a call when it was done. Anyone know how long this should take?
 
I went into my local dealer yesterday to get Connect Me activated on my C350e and because the technician was busy they took my details and said they'd give me a call when it was done. Anyone know how long this should take?

Think it just internet activation, dealer just enters a few details about you and your car, takes a few minutes. Then you get an email to activate, which takes a few minutes.
 
I'm assuming there is some separate activation needed for the iPhone app?

I can log in to the website no problem, but the iPhone app says I need to go to the dealer. Their "Star Expert" was supposed to be looking at it today, but I guess either she didn't or there is some other activation needed.
 
I've never been able to download the App as it errored on first download and it's not available in the App Store. Only available via a special direct download initiated on first connection to the car I think.

Anyway there is the web version, accessible here
https://me.secure.mercedes-benz.com/ciam/
 
I got this activated this afternoon, the guy said it might take a few days for some of the features to show up. Is this true? Currently I've got nothing showing in the vehicles tab on the browser based app (iPhone).
 
I got this activated this afternoon, the guy said it might take a few days for some of the features to show up. Is this true? Currently I've got nothing showing in the vehicles tab on the browser based app (iPhone).

I seemed to have access more or less right away while I was waiting for payment to clear, the dealer set me up.
 
Very good. Thank you
 
Hi guys, sorry To bring this up again. I'm having a nightmare getting getting my Mercedes me set up.. I'm guessing my car doesn't need retro fitting with an adaptor because it's a 2014 car and a simple phone call to the Mercedes me team made the Mercedes
Me app come to life.

Anyway, on the app it says no services have been enabled and that I have go to the portal to enable them..
When I get to the portal it just says that Mercedes me & live trafic are activating & that once I have a date connection with the car It will activate.
I've rode around today in the car for quite a while, phone connected via Bluetooth and hotspot turned on so there's a date connection. But, still no activation.

I've attached photos. Thanks for any help
attachment.php
 
I was on the portal last night and it's not the easiest to find your way around but somewhere there is a list of services that you have to manually activate and accept the terms of use or you can select all in one go and agree to the terms.

When done correctly you will receive an email confirming activation.


Sent from my iPad using Tapatalk
 
I was on the portal last night and it's not the easiest to find your way around but somewhere there is a list of services that you have to manually activate and accept the terms of use or you can select all in one go and agree to the terms.

When done correctly you will receive an email confirming activation.


Sent from my iPad using Tapatalk

Do you have a rough guide on how to do it? All I can get is that there is a change of services and that once a data connection has been established the services would be transferred.
 
Maco - I had to take my (2015 C class) to the dealer for a software update. When they did it the car immediately connected.
 
Do you have a rough guide on how to do it? All I can get is that there is a change of services and that once a data connection has been established the services would be transferred.



Go to the MercedesMe site, log in and you should see a picture of your car with its registration number.

Select your car, when page is loaded scroll to 'Manage Mercedes Me Connect'

Select and scroll to 'Manage Services'

Select this and you will see all that are applicable to your car, you then have to select each or all and agree to the T&C.

If you do not see this I suspect a trip to the dealership is required, they normally have a technical expert who can assist.

Hope this helps.


Sent from my iPad using Tapatalk
 
Go to the MercedesMe site, log in and you should see a picture of your car with its registration number.

Select your car, when page is loaded scroll to 'Manage Mercedes Me Connect'

Select and scroll to 'Manage Services'

Select this and you will see all that are applicable to your car, you then have to select each or all and agree to the T&C.

If you do not see this I suspect a trip to the dealership is required, they normally have a technical expert who can assist.

Hope this helps.




Sent from my iPad using Tapatalk


Hi there, when I click manage services it says, live trafic & Mercedes me are activating and 0/2 have processed. After that it says when they car is turned on or there is a data connection the services will be transferred.
It's been like that since yesterday morning. Looks like a trip to a dealer is in need.
 
Hi guys,

Just to give you my experience with access to Mercedes Me. I downloaded the app and registered through the link which took you to the website. After registering I was told I had limited functionality, remote locking, tracking etc was unavailable as Mercedes Benz needed verification that I was the actual owner of the car and required the v5 log book and passport ID to be brought to my local dealer before they could connect me for those services for security reasons.

As my vehicle is a lease I am not the registered owner which remains with Mercedes financial services, I am the registered keeper of the vehicle however they retained the v5 logbook which threw a so called spanner in the works.

After speaking to Mercedes financial services they basically said it's not a problem, all I had to do was get my local dealer to call them to verify I was in fact the registered keeper of the car and they would then connect me to Mercedes Me full services.

Received an email from my local dealer Mercedes Benz Bham Central yesterday to say that they had contacted Mercedes finance and they confirmed everything and my car is now ready to be fully set up with Mercedes Me, could I bring the car to them on Tuesday and the process will take about 20 mins to get the car connected and services up and running.

Pretty simple in the end after a few quick calls.

Regards
H
 
Does the app for Mercedes Me now work on iOS 10? Apparently it only works on iOS versions up to 8...
 
Yes it works on IOS10
 

Users who are viewing this thread

Back
Top Bottom