Mercedes e220 cdi, w210 2000 reg

Discussion in 'Engine' started by BAZ-500SL, Jul 11, 2016.

  1. BAZ-500SL

    BAZ-500SL Active Member

    Messages:
    155
    Joined:
    Jul 2, 2014
    Car:
    500sl
    Hello guys. Got a issue with the w210, basically the car starts up fine I drive it like normal, when I leave it parked for a bit it sometimes starts up like normal, but sometimes it refuses to start, if I get it towed and attempt to start it she starts up fine, if I spray easy start in the air Intake it starts up, can anyone shine any light on what's I should be looking at, thanks for any help In advance
     
  2. bob6600

    bob6600 MB Enthusiast

    Messages:
    5,814
    Joined:
    Jan 3, 2013
    Car:
    AUDI S8 V10, S210 E320 CDI (R.I.P.)
    Sounds like the CPS is faulty.

    Typical symptoms are trouble starting when engine is warm
     
  3. OP
    OP
    BAZ-500SL

    BAZ-500SL Active Member

    Messages:
    155
    Joined:
    Jul 2, 2014
    Car:
    500sl
    Thanks bob, is it a hard job to do or can a home mechanic have a attempt lol thanks
     
  4. bob6600

    bob6600 MB Enthusiast

    Messages:
    5,814
    Joined:
    Jan 3, 2013
    Car:
    AUDI S8 V10, S210 E320 CDI (R.I.P.)
    i don't think they are hard to do, it could be a fiddly to get to. Can't comment on how difficult it is on your particular engine but I'm sure someone will be along who can :thumb:
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.