mercedes ML 300 Ignition Issue?

kylezx7r

New Member
Joined
Sep 23, 2014
Messages
29
Car
mercedes M300 Sport
Hi Guys, first time posting on a forum so be gentle.

I have a 2010 mercedes ML 300 Sport (W164) and on the odd occasion when you turn the key nothing happens, nothing lights up and the engine wont turn over. This may last around 10 - 20 seconds or so then the car will start and it will be fine for a week or 2 weeks then it does it again. Very intermittant and at the minute not happening all the time (Once a week maybe).

I changed the battery in the key and took the car into MB for a diagnostics check for £70 who said they couldnt find anything wrong with it but it still does it.

Can anyone shine any light on this as i do not want it to develop into a major fault as i do alot of travelling up and down the country
 

boblydon

Active Member
Joined
Jan 19, 2014
Messages
79
Car
merc e320...jaguar xk
I have the same issue with a 2010 ML 350, however this vehicle is one which i am repairing....unfortunatly for me, mine won't start, won't put lights on etc etc.

Having read loads of threads i hoped it may have been the EIS module, theres loads of info about these going faulty...however most people describe the same intermitant problems you are having.

I sent mine away to Sinspeed to get it checked out, only for them to have it 2 weeks then tell me there software does not do my EIS, I was not happy as i had given them all the info, vin, model year, symptoms etc etc before i wasted my time and money sending it.

Bob
 

boblydon

Active Member
Joined
Jan 19, 2014
Messages
79
Car
merc e320...jaguar xk
meant to add, no one replied to me either when i was asking for help.......must be one of the few faults that our fellow site members know nothing about

bob
 
OP
OP
kylezx7r

kylezx7r

New Member
Joined
Sep 23, 2014
Messages
29
Car
mercedes M300 Sport
Yes everything I have read points completely to the EIS and MB themselves even said its likely to be the EIS but said at the time they couldn't find a fault.

I'm toying with the idea of replacing it anyway for piece of mind. I know MB have issued recalls on the same fault but unfortunately not on the W164
 

Users Who Are Viewing This Thread (Users: 0, Guests: 1)

Top Bottom