Merdeces R129 noise when accelerating

Page may contain affiliate links. Please see terms for details.

volviak

New Member
Joined
Apr 20, 2022
Messages
12
Location
london
Car
mercedes sl320 R129
Hi all and Happy New Year.

I have an issue with my 2000 Mercedes SL320 R129 . Rattling Metalic noise coming from underneath.
It started a year ago. When I turned on the engine, the noise started from underneath. Ive been told its a Catalytic Converter which I replaced shortly after.
The noise stopped. Then in a couple of months I was at the roundabout and tried to accelerate. The car accelerated but I felt this rattling noise ane vibration on the foot rest (especially on the passangers side). That was quite scary! Since then I tried everything, the car has been checked multiple times underneath and everything seems fine. The noise and vibrations comes on and off. It doesn't necessarily happen every time I accelerate. It happens occasionally when I accelerate from 0mph, or accelerating from 0mph and turning the wheel or accelerating uphill. Tje gearbox has been checked and its all good. I just dont know what to do. I hope someone can help. Thanks a lot. B.
 
Hi all and Happy New Year.

I have an issue with my 2000 Mercedes SL320 R129 . Rattling Metalic noise coming from underneath.
It started a year ago. When I turned on the engine, the noise started from underneath. Ive been told its a Catalytic Converter which I replaced shortly after.
The noise stopped. Then in a couple of months I was at the roundabout and tried to accelerate. The car accelerated but I felt this rattling noise ane vibration on the foot rest (especially on the passangers side). That was quite scary! Since then I tried everything, the car has been checked multiple times underneath and everything seems fine. The noise and vibrations comes on and off. It doesn't necessarily happen every time I accelerate. It happens occasionally when I accelerate from 0mph, or accelerating from 0mph and turning the wheel or accelerating uphill. Tje gearbox has been checked and its all good. I just dont know what to do. I hope someone can help. Thanks a lot. B.
Loose heat shield?
 
Where you’ve had the cat replaced, check the clearances and fit. It might be twisting and rubbing a bit.

Does it sound like a cat? There are probably two if you have an v6 and if one has gone the other won’t be far behind. Not familiar with the 320 but it’s probably a v6 at that age?
 
Where did you have it done?

My brother has the same issue with his R129 500SL
 
Where did you have it done?

My brother has the same issue with his R129 500SL
Any garage with a lift can do it. Usually the shield has corroded around the small retaining nuts and fallen down. One inch repair washers from B&Q between the nut and shield will hold it up for a few more years.
 
Hi,
A couple of thoughts...
I know the distinctive sound of a broken catalytic convertor, my car has two , one of which was replaced because it was rattling.
The heat shields are very light like disposable foil trays, they wrap around the catalytic convertors if I go through a puddle and rattle against the cat. There are a few heat shields which could cause noise for you maybe because they are bent or corroded or loose.
Another obvious rattle comes from the automatic gear shifter bushing which wears. It is a little green one that attaches the lever under the gear shifter to the gearbox mechanism. For me it was when taking off then with a little throttle it would even out.
There is a steering idler which can cause vibration if worn but not really any rattle.
I have an as yet unresolved rattle in my 99sl320 but that might be for another day.
Kindliest regardations,
D.
 
Sorry, I stampeded through the thread and neglected your comment that it was a heatshield problem and is now resolved - great news. Enjoy.
 
Where did you have it done?

My brother has the same issue with his R129 500SL
Hi.
Merc Care in Barnet.
I highly recommend that place..
 

Users who are viewing this thread

Back
Top Bottom