Meredes 300GE Long cranking/hard Start

Discussion in 'Engine' started by zjamiez, Sep 19, 2011.

  1. zjamiez

    zjamiez New Member

    Messages:
    16
    Joined:
    Jun 27, 2011
    Car:
    C43
    I have done a lot of research on this minor problem but i have a 91 300ge and it seems to have to crank over a long time when cold and hot.

    I have changed all the obvious such as spark plugs and ht leads. Has anyone got any advice ?
     
  2. grober

    grober MB Master

    Messages:
    27,862
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    Get it on an old fashioned oscilloscope engine analyser with someone who knows how to use it. Sounds as if your ignition is a bit under par. " Off the wall/guess fault" dodgy engine earth strap leading to too much voltage drop while cranking over?
     
  3. jonnyboy

    jonnyboy MB Enthusiast

    Messages:
    2,562
    Joined:
    Nov 27, 2005
    Location:
    Camberley, Surrey
    Car:
    1991 sl300-24 project,s124 280,w115 no interior, w108 project no engine
    has a gelandewagen M103 got an OVP relay? I forget. Could be that, they can cause all sorts of weird and wonderful faults!
     
  4. grober

    grober MB Master

    Messages:
    27,862
    Joined:
    Jun 22, 2003
    Location:
    Perth, Scotland
    Car:
    W204 C200CDI Estate
    It will have one.
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.