Misfire ?

Discussion in 'Engine' started by tromppost, Dec 14, 2008.

  1. tromppost

    tromppost Hardcore MB Enthusiast

    Messages:
    757
    Joined:
    Dec 27, 2007
    Location:
    South East
    Car:
    w220 s320 2000
    I have a 2000 S320 Petrol. It's been sat parked down the side for house for the last 12 weeks only moved every two or three weeks for a quick wash and let it idle for 30mins. I have done this often over the six years when I am not using it but this time it misfires (sounds like it is hitting the rev limiter)I think. When I rev the engine to over 4000 rpm it starts to misfire. but when the car is driven it will not misfire and change gear at the red line.
    Drove 40 miles today and it drivers just fine but still if rev in park to over 4000 rpm it misfire. A bit long winded but I think that explains it any thoughts would be of help.
     
  2. Dieselman

    Dieselman Banned

    Messages:
    34,206
    Joined:
    Jul 13, 2003
    Car:
    Peugeot 403 Convertible
    That's normal. There is a limiter at 4k revs in neutral. Why do you want to rev it past 4k when in neutral.?
     
  3. OP
    OP
    tromppost

    tromppost Hardcore MB Enthusiast

    Messages:
    757
    Joined:
    Dec 27, 2007
    Location:
    South East
    Car:
    w220 s320 2000
    Thanks for the reply that makes sense. I only happened to do last week when I parked it up for the week after washing it. I am no Hooligan!
     
Tags:

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.